Docker 搭建mysql 连接超时问题,xxl-job启动mysql连接报错

1.本地连接Navicat报错信息,猜测是navicat默认连接超时导致的,后面换成idea一个插件虽然慢但连接上了

2013 - Lost connection to MySQL server at reading initial communication packet

2.启动xxl-job会报错,网上有人mysql驱动与数据库不匹配,可以忽略,因为我尝试修改连接超时由原来的10秒改成60秒,虽然慢但不报错了,说明问题是连接尝试导致的

MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.

还是不满意! 修改mysql配置,skip-name-resolve 禁用dns解析

首先找到docker 启动mysql容器的脚本,确定外部挂载配置目录(没有挂载目录,需要进入mysql容器修改,这里不赘述,自行百度)

javascript 复制代码
# 查看容器id
docker ps 

cd /usr/local/mysql/conf
ll

# 会看见一个my.cnf文件
vim my.cnf

# 在[mysqld]下面加一行
skip-name-resolve

# 重启mysql容器
docker restart 容器id

瞬间连接成功

相关推荐
我叫洋洋5 分钟前
Cadence CIS 元器件库合并实战:3000+ 焊盘、156 个符号零冲突并入自有库
数据库·单片机·嵌入式硬件·oracle·电路
AI 编程助手GPT7 分钟前
GPT-6 Luna (Batch) 批量处理性能与质量深度评测
数据库·gpt·batch
quweiie20 分钟前
Neo4j Community 安全访问配置总结
数据库·centos·neo4j
꯭自꯭闭꯭1 小时前
DM7主备升级方案
linux·服务器·数据库
蜗牛互联网2 小时前
MongoDB Atlas Agent Engine之后,如何用版本门禁防止陈旧写入
java·数据库·人工智能·后端·mongodb
IvorySQL2 小时前
PostgreSQL 日报 |PostgreSQL 19 Beta 4 发布(9 月 25 日)
数据库·postgresql
科技研学社2 小时前
绿色合规时代,碳足迹与ESG倒逼服装工厂工序升级
数据库·人工智能
赵渝强老师3 小时前
【赵渝强老师】崖山数据库的数据库文件
数据库·国产数据库·yashandb·崖山数据库
做运维的阿瑞3 小时前
多表查询基础:INNER JOIN、LEFT JOIN、RIGHT JOIN
数据库·sql·mysql·算法
IvorySQL4 小时前
PostgreSQL 日报 | 可见性映射数据损坏修复(9 月 26 日)
数据库·postgresql