Docker 搭建mysql 连接超时问题,xxl-job启动mysql连接报错

1.本地连接Navicat报错信息,猜测是navicat默认连接超时导致的,后面换成idea一个插件虽然慢但连接上了

2013 - Lost connection to MySQL server at reading initial communication packet

2.启动xxl-job会报错,网上有人mysql驱动与数据库不匹配,可以忽略,因为我尝试修改连接超时由原来的10秒改成60秒,虽然慢但不报错了,说明问题是连接尝试导致的

MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.

还是不满意! 修改mysql配置,skip-name-resolve 禁用dns解析

首先找到docker 启动mysql容器的脚本,确定外部挂载配置目录(没有挂载目录,需要进入mysql容器修改,这里不赘述,自行百度)

javascript 复制代码
# 查看容器id
docker ps 

cd /usr/local/mysql/conf
ll

# 会看见一个my.cnf文件
vim my.cnf

# 在[mysqld]下面加一行
skip-name-resolve

# 重启mysql容器
docker restart 容器id

瞬间连接成功

相关推荐
Rain的Java大神之路3 小时前
如何快速上传10G文件
java·spring boot·redis·后端·mysql·spring cloud·面试
十二同学啊3 小时前
向量数据库:从核心原理到 RAG 与 Java 实战
数据库
蓝速科技4 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
大海星辰7985 小时前
一次对账SQL“灵异事件”排查:NOT IN返回空集的坑
mysql
Linux-lucky5 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
一 乐6 小时前
二手交易平台|基于springboot + vue二手交易平台(源码+数据库+文档)
java·数据库·vue.js·spring boot·小程序
SelectDB7 小时前
同等资源下 Apache Doris 4.2 vs StarRocks 4.1.1:1TB SSB 与 TPC-H 性能实测
大数据·数据库·数据分析
这个DBA有点耶7 小时前
数据库集群与分布式架构:三条技术路线对比、金仓KES RAC实测数据与决策框架
数据库·程序员·架构
MayBaymax7 小时前
MongoDB 索引与事务
java·数据库·mongodb
SelectDB7 小时前
Doris vs ClickHouse:企业 OLAP 走向下一阶段,两种技术路线如何选择
大数据·数据库·数据分析