CentOS7安装RabbitMQ-3.13.7、修改端口号

本文安装版本:

Erlang:26.0

官网下载地址 Erlang

RabbitMQ:3.13.7

官网下载地址 RabbitMQ

RabbitMQ和Erlang对应关系查看:https://www.rabbitmq.com/which-erlang.html

注:安装erlang之前先安装下依赖文件(这一步不要忘掉了,不然后面./configure的时候要报错)

bash 复制代码
yum install gcc glibc-devel make ncurses-devel openssl-devel xmlto

安装Erlang

1、下载erlang安装包并解压

bash 复制代码
wget https://erlang.org/download/otp_src_26.0.tar.gz

tar -zxvf otp_src_26.0.tar.gz

2、编译安装,路径自定义

bash 复制代码
cd otp_src_26.0/

./configure --prefix=/usr/local/erlang

make && make install

3、测试是否安装成功

bash 复制代码
cd /usr/local/erlang/bin/

./erl

若出现以下界面,则说明Erlang配置OK了

输入 halt(). 退出控制台,注意后面有个点

4、配置环境变量

bash 复制代码
vim /etc/profile

# 加入如下配置
export PATH=$PATH:/usr/local/erlang/bin

# 保存退出后,使该配置文件即刻生效
source /etc/profile

安装RabbitMQ

1、下载RabbitMQ安装包并解压

bash 复制代码
wget https://github.com/rabbitmq/rabbitmq-server/releases/download/v3.13.7/rabbitmq-server-generic-unix-3.13.7.tar.xz

xz -d rabbitmq-server-generic-unix-3.13.7.tar.xz

tar -xvf rabbitmq-server-generic-unix-3.13.7.tar

2、 配置环境变量

bash 复制代码
vim /etc/profile

# 加入如下配置
export PATH=$PATH:/home/RabbitMQ/rabbitmq_server-3.13.7/sbin

# 保存退出后,使该配置文件即刻生效
source /etc/profile

3、RabbitMQ的基本操作

bash 复制代码
# 启动
rabbitmq-server -detached

# 关闭
rabbitmqctl stop

# 查看状态
rabbitmqctl status

4、配置RabbitMQ网页管理插件

bash 复制代码
# 启用插件
rabbitmq-plugins enable rabbitmq_management

# 默认来宾用户:guest, 来宾用户密码:guest

5、开启RabbitMQ远程访问

bash 复制代码
# 添加用户
rabbitmqctl add_user Arvin Arvin888

# 添加权限
rabbitmqctl set_permissions -p "/" Arvin ".*" ".*" ".*"

# 修改用户角色
rabbitmqctl set_user_tags Arvin administrator

修改RabbitMQ默认端口,开启远程访问

RabbitMQ默认开启的端口:

4369:erlang发现口

5672:client端通信口,客户端要连接RabbitMQ服务时要用到

15672:后台管理界面ui端口,进入管理后台时访问url如:http://localhost:15672/

25672:server间内部通信口

在生产环境下,出于安全等原因希望修改掉默认的端口号。安装RabbitMQ后发现找不到配置文件;事实上RabbitMQ在某个版本后(具体哪个暂不清楚)并没有生成配置文件,需要手动添加配置文件。

官方建议配置文件的位置:https://www.rabbitmq.com/docs/configure#config-location

bash 复制代码
vim /home/RabbitMQ/rabbitmq_server-3.13.7/etc/rabbitmq/rabbitmq.conf

#AMQP 0-9-1 and 1.0 port,默认5672
listeners.tcp.default = 0.0.0.0:8620

#web管理,默认15672
management.tcp.port = 8621
management.tcp.ip   = 0.0.0.0

# 保存,并重启RabbitMQ服务。

使用 netstat -lntp 查看端口监听情况

相关推荐
大侠归来几秒前
Ubuntu 搭建 APUE 环境:从源码编译到第一个示例跑通
linux·运维·ubuntu
北京中科新远科技2 小时前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv2 小时前
【无标题】
linux·运维·服务器
wp123_12 小时前
TLVR 电感在 AI 服务器电源中的应用与市场前景分析
服务器·人工智能·科技·ai·硬件工程
周洲08302 小时前
STM32片内Flash读写深度详解|掉电参数保存、底层原理
linux·前端·stm32
shimly1234563 小时前
比 find + grep 更好用的 nm + addr2line
linux
迷途之人不知返3 小时前
【进程控制】-3-进程等待
linux
ycvv3 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup3 小时前
包管理器和vim
linux·服务器
一颗小树x3 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级