【题目来源】
https://www.luogu.com.cn/problem/P1226
【题目描述】
给你三个整数 a,b,p,求 a^b mod p。
【输入格式】
输入只有一行三个整数,分别代表 a,b,p。
【输出格式】
输出一行一个字符串 a^b mod p=s,其中 a,b,p 分别为题目给定的值,s 为运算结果。
【输入样例】
2 10 9
【输出样例】
2^10 mod 9=7
【说明/提示】
样例解释:2^10 =1024,1024 mod 9=7。
数据规模与约定:对于 100% 的数据,保证 0≤a,b<2^31,a+b>0,2≤p<2^31。
【算法分析】
● 快速幂,又称二进制取幂,是一个以 的时间复杂度计算 的小技巧,而暴力的计算需要 的时间复杂度。
● 快速幂的原理?
答:快速幂的原理为"++将求幂的任务按照指数 的++++二进制表示++ ++分割成更小的任务++ "。例如:
因为 有 个二进制位,因此当知道了 后,我们只需计算 次乘法就可以计算出 。
● 快速幂经典代码
cpp
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
int fastPow(LL a,LL n) {
LL ans=1;
while(n){
if(n & 1) ans=ans*a;
n>>=1;
a=a*a;
}
return ans;
}
int main() {
int a,n;
cin>>a>>n;
cout<<fastPow(a,n)<<endl;
}
/*
in:6 8
out:1679616
*/
● 带取模的快速幂代码
计算过程中,为了防止溢出,需要进行"取模"运算,其运算规则如下:
(a+b)%p=(a%p+b%p)%p
(a-b)%p=(a%p-b%p)%p
(a*b)%p=(a%p*b%p)%p
【算法代码】
cpp
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
int fastPow(LL a,LL b,LL p) {
LL ans=1;
while(b){
if(b & 1) ans=ans*a%p;
b>>=1;
a=a*a%p;
}
return ans%p;
}
int main() {
int a,b,p;
cin>>a>>b>>p;
cout<<a<<"^"<<b<<" mod "<<p<<"="<<fastPow(a,b,p)%p;
}
/*
in:2 10 9
out:2^10 mod 9=7
*/
【参考文献】
https://www.cnblogs.com/littlehb/p/15588930.html
https://oi-wiki.org/math/binary-exponentiation/