【Jenkins实战】Windows安装服务启动失败

写此篇短文,望告诫后人。

如果你之前装过Jenkins,出于换域账号/本地帐号的原因想重新安装,你大概率会遇上一次Jenkins服务启动失败提示:

Jenkins failed to start - Verify that you have sufficient privileges to start system services

如果遇上了,千万别点多次重试,尤其是你要用的账号是你现在登桌面的账号。多次netlogon登录失败会导致账号被锁,与输入错误密码多次同理。

当出现这个提示时, 不要点重试,立即打开services.msc,找到Jenkins服务,右键打开属性。

先点一次Local System account,点OK。然后再回到这个属性页面,选择This account,重新输入登录凭据。

最后再回到Jenkins安装界面,点retry,理论上会解决问题。

相关推荐
不会就选b7 小时前
Linux之TCP理论<1>
linux·运维·服务器
倔强的石头1068 小时前
应用账号最小权限实践:读写账号、报表账号、运维账号分层
java·运维·开发语言
Android系统攻城狮9 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
_upupup10 小时前
Linux中的自动化构建——make/Makefile
linux·运维·自动化
还卿一钵无情泪11 小时前
Docker 部署Unsloth 绕开环境配置难题
运维·人工智能·docker·ai·容器·nlp·干货
打工仔折腾 AI12 小时前
Docker镜像分层与卷挂载到底怎么工作:一次文件系统层面的实测分析
运维·人工智能·后端·python·docker·容器·性能优化
大猫会长12 小时前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
夜之眷属13 小时前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
极客先躯13 小时前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
韩振方13 小时前
为什么服务显示占了 8G,实际内存却没那么多?
运维