docker desktop es windows解决vm.max_map_count [65530] is too low 问题

如果你使用windows上的docker desktop 搭建es相关的应用,大概率会遇到vm.vm.max_map_count 65530 is too low这个错误,本篇文章分享下怎么解决这个问题,主要分享长期解决的方法,重启机器之后也能生效的方法。

这个错误的详细信息是这样的

ERROR: 1 bootstrap checks failed

1\]: max virtual memory areas vm.max_map_count \[65530\] is too low, increase to at least \[262144

  • 临时解决(重启失效)
    执行如下两个命令
  1. wsl -d docker-desktop
  2. echo 262144 >>/proc/sys/vm/max_map_count

执行完成后再启动es就不会报错了。

  • 长期解决(重启生效)
  1. 在windows的用户目录下(C:\Users<username>)创建或编辑.wslconfig文件
  2. 增加如下内容(注意wsl2不要忽略)

    wsl2

    kernelCommandLine = "sysctl.vm.max_map_count=262144"

测试是否生效

  1. wsl --shutodwn 关闭
  2. wsl 启动
  3. 输入命令 wsl -d docker-desktop sysctl vm.max_map_count
  4. 显示 vm.max_map_count=262144 则成功

本篇文章的解法参考了它: https://stackoverflow.com/questions/69214301/using-docker-desktop-for-windows-how-can-sysctl-parameters-be-configured-to-sur/69294687#69294687

相关推荐
小羊没烦恼!2 小时前
初探性能优化——2个月到4小时的性能提升
java·开发语言·windows·算法·c#
rockmelodies2 小时前
# Windows Server2008 R2 Standard(SP1镜像U盘)重置本地管理员密码【完整详细步骤】
windows·密码破解
分布式存储与RustFS3 小时前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心5 小时前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing5 小时前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
guo_wen_qiang5 小时前
上传本地镜像到harbor中
docker·容器·持续部署
Elasticsearch5 小时前
Elastic Observability 的跨项目搜索:通过一个查询搜索所有关联项目
elasticsearch
羑悻的小杀马特6 小时前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
BianHuanShiZhe6 小时前
docker常见命令
docker
Elasticsearch7 小时前
Elasticsearch 中的 agentic 工作流:暂停 AI agent 等待人工审批,72 小时后恢复
elasticsearch