1047 Student List for Course (25)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意:给出选课人数和课程数目,然后再给出每个人的选课情况,请针对每门课程输出选课人数以及所有选该课的学生姓名,按照字典序输出。
分析:用vector存储选课的学生,string记录学生的姓名。

cpp 复制代码
#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include   <string>
#include   <vector>
#include   <cstdio>
#include    <queue>
#include    <stack>
#include    <ctime>
#include    <cmath>
using namespace std;

int main(void)
{
    #ifdef test
    freopen("in.txt","r",stdin);
    //freopen("in.txt","w",stdout);
    clock_t start=clock();
    #endif //test

    int n,k;scanf("%d%d",&n,&k);
    vector<string>s[5+k];
    for(int i=0;i<n;++i)
    {
        string ss;cin>>ss;
        int cnt;scanf("%d",&cnt);
        for(int j=0;j<cnt;++j)
        {
            int a;scanf("%d",&a);
            s[a].push_back(ss);
        }
    }
    for(int i=1;i<=k;++i)
    {
        printf("%d %lu\n",i,s[i].size());
        if(s[i].size())
        {
            sort(s[i].begin(),s[i].end());
            for(auto it=s[i].begin();it!=s[i].end();++it)
                cout<<*it<<'\n';
        }
    }

    #ifdef test
    clockid_t end=clock();
    double endtime=(double)(end-start)/CLOCKS_PER_SEC;
    printf("\n\n\n\n\n");
    cout<<"Total time:"<<endtime<<"s"<<endl;        //s为单位
    cout<<"Total time:"<<endtime*1000<<"ms"<<endl;    //ms为单位
    #endif //test
    return 0;
}
相关推荐
圣保罗的大教堂8 天前
1028 List Sorting (25)
pat考试
哈哈,柳暗花明12 天前
软件设计师笔记-数据结构
pat考试
绯樱殇雪24 天前
编程题 7-29 删除字符串中的子串【PAT】
c++·pat考试
绯樱殇雪2 个月前
编程题 7-14 求整数段和【PAT】
c++·pat考试
C盘清理2 个月前
2025考研倒计时 考研时间公布了 你准备好复习冲刺了吗?
考研·倒计时·pat考试·高考·倒计时软件·日期倒计时
绯樱殇雪2 个月前
函数题 6-8 简单阶乘计算【PAT】
c·pat考试
Moliay4 个月前
1117 数字之王
c语言·c++·算法·pat考试·简单模拟
zhang98800005 个月前
2024-2025最新软考系统架构设计师的复习资料教材,解决如何快速高效通过该考试,试题的重点和难点在哪里?案例分析题和论文题的要点和踩坑点分析
考研·面试·职场和发展·系统架构·运维开发·pat考试·学习方法
Moliay5 个月前
1052 卖个萌(测试点1,2)
笔记·算法·pat考试·简单模拟