1047 Student List for Course (25)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意:给出选课人数和课程数目,然后再给出每个人的选课情况,请针对每门课程输出选课人数以及所有选该课的学生姓名,按照字典序输出。
分析:用vector存储选课的学生,string记录学生的姓名。

cpp 复制代码
#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include   <string>
#include   <vector>
#include   <cstdio>
#include    <queue>
#include    <stack>
#include    <ctime>
#include    <cmath>
using namespace std;

int main(void)
{
    #ifdef test
    freopen("in.txt","r",stdin);
    //freopen("in.txt","w",stdout);
    clock_t start=clock();
    #endif //test

    int n,k;scanf("%d%d",&n,&k);
    vector<string>s[5+k];
    for(int i=0;i<n;++i)
    {
        string ss;cin>>ss;
        int cnt;scanf("%d",&cnt);
        for(int j=0;j<cnt;++j)
        {
            int a;scanf("%d",&a);
            s[a].push_back(ss);
        }
    }
    for(int i=1;i<=k;++i)
    {
        printf("%d %lu\n",i,s[i].size());
        if(s[i].size())
        {
            sort(s[i].begin(),s[i].end());
            for(auto it=s[i].begin();it!=s[i].end();++it)
                cout<<*it<<'\n';
        }
    }

    #ifdef test
    clockid_t end=clock();
    double endtime=(double)(end-start)/CLOCKS_PER_SEC;
    printf("\n\n\n\n\n");
    cout<<"Total time:"<<endtime<<"s"<<endl;        //s为单位
    cout<<"Total time:"<<endtime*1000<<"ms"<<endl;    //ms为单位
    #endif //test
    return 0;
}
相关推荐
圣保罗的大教堂18 小时前
1170 Safari Park (25)
pat考试
圣保罗的大教堂3 天前
1166 Summit (25)
pat考试
圣保罗的大教堂5 天前
1164 Good in C (20)
pat考试
圣保罗的大教堂6 天前
1161 Merging Linked Lists (25)
pat考试
圣保罗的大教堂7 天前
1156 Sexy Primes (20)
pat考试
圣保罗的大教堂10 天前
1150 Travelling Salesman Problem (25)
pat考试
圣保罗的大教堂17 天前
1133 Splitting A Linked List (25)
pat考试
圣保罗的大教堂1 个月前
1097 Deduplication on a Linked List (25)
pat考试
圣保罗的大教堂1 个月前
1089 Insert or Merge (25)
pat考试
圣保罗的大教堂1 个月前
1081 Rational Sum (20)
pat考试