【WSL+Ubuntu】默认用户被意外变更为 root 后切回原来的默认用户

引言

在使用 Windows Subsystem for Linux (WSL) Ubuntu 时,在 ~ 目录下使用 ls 命令,发现所有文件都消失了,让我误以为文件被清空了。实际上是因为WSL Ubuntu的默认用户被意外地改变为了 root。那么,如何恢复并切回原来的默认用户呢?


步骤

  1. 关闭当前运行的WSL。
bash 复制代码
wsl --shutdown

这个命令会立即关闭所有正在运行的WSL实例。

  1. 设置WSL的默认用户。
bash 复制代码
ubuntu config --default-user <用户名>

在 <用户名> 的位置,填入原来的默认用户名。这个命令会将WSL的默认用户设置回原来的用户。

相关推荐
KING-WU5121 小时前
Linux 工具之Make 与 Makefile
java·linux·服务器
Lsetea2 小时前
OpenSSL报certificate is not yet valid:error 9与notBefore时间排查
linux·运维·https·ssl证书·openssl
魔法阵维护师2 小时前
Linux 命令行入门踩坑记录:从 VMware 装系统到文件管理
linux·运维·服务器
飞飞传输2 小时前
业务系统文件安全检测怎么做?生物医药企业选型与建设指南
大数据·运维·安全
姜鱼问生2 小时前
docker exec 排查容器问题:从日志到进程
运维·网络·数据库·docker·容器
qq_543447822 小时前
DNS解析怎么排查?故障处理与运维实用手册
运维·服务器·网络·php
DeviceHub2 小时前
AI服务器电源设计进阶:TLVR电感的应用解析与选型验证指南
运维·服务器·人工智能
Apipi*2 小时前
30天速通Linux 第七章进程间通信
linux·运维·服务器
emo_2b2 小时前
Pycharm配置conda解释器时遇到的问题及解决方法
linux·pycharm·conda
迪康软件zz2 小时前
终端审批体系怎么搭?从模板配置到业务连续性
运维·安全·自动化运维