故障处理--kuboard无法访问,etcd磁盘空间不足

问题现象:

kuboard页面报错

排查过程:

1、查看kuboard是否正常。

2、查看kuboard容器的日志:

powershell 复制代码
docker logs -f  --tail=10  kuboard
大概内容如下:
level=error msg="failed to rotate keys: etcdserver: mvcc: database space exceeded"

表示etcd磁盘空间不足,etcd默认的空间配额限制为2G,超出空间配额限制就会影响服务,需要定期清理。

3、查看etcd的启动配置entrypoint.sh,发现没有设置etcd磁盘大小,默认为2G

处理过程:

1、查看kuboard信息,找到kuboard-data的位置

2、查看etcd-data大小。发现db大于2G

3、进入容器内部,查看告警信息。alarm:nospace,也表示空间不足

4、查看etcd告警

powershell 复制代码
[root@master1 etcd-data]# docker exec -it kuboard /bin/sh
# ETCDCTL_API=3 etcdctl --endpoints="http://127.0.0.1:2379" alarm list
memberID:6460912315094810421 alarm:NOSPACE 

5、按照如下步骤临时处理

powershell 复制代码
# 备份db
etcdctl snapshot save backup.db
# 查看当前版本
rev=$(ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 endpoint status --write-out="json" | egrep -o '"revision":[0-9]*' | egrep -o '[0-9].*')
# 压缩旧版本
ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 compact $rev
# 整理多余的空间
ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 defrag
# 取消告警信息(之前有nospace的告警)
ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 alarm disarm
# 再次查看etcd的状态(发现ERROR字段已为空)
ETCDCTL_API=3 etcdctl --endpoints="http://127.0.0.1:2379" --write-out=table endpoint status

整理多余的空间时有如下报错

错误原因

etcdctl 的默认命令超时为 5 秒,但碎片整理花费的时间比这更长。

解决方案

指定超时时间 --command-timeout

powershell 复制代码
# 整理多余的空间
# ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 --command-timeout=30s defrag
Finished defragmenting etcd member[http://127.0.0.1:2379]
# 取消告警信息,不取消告警,ectd一样不可用
# ETCDCTL_API=3 etcdctl --endpoints=http://127.0.0.1:2379 alarm disarm
memberID:6460912315094810421 alarm:NOSPACE 
# 再次查看ETCD存储使用情况
# ETCDCTL_API=3 etcdctl --endpoints="http://127.0.0.1:2379" --write-out=table endpoint status

故障解决:

再次查看etcd-data文件大小

相关推荐
程序边界几秒前
迁移评估不再拍脑袋,这个数据迁移工具的量化报告把我救了(上)
数据库
阿狗童鞋33 分钟前
Redis实战指南
数据库·redis·缓存
lupai2 小时前
维修保养记录精准版 API 对接实战指南
数据库·python
2601_952196364 小时前
计算机科学与技术专业应届生投商业分析岗,需要哪些额外能力?
数据库·oracle
皮皮学姐分享-ppx4 小时前
地级市、省级人才政策强度测算(2000-2025)
大数据·数据库·人工智能·百度·高考
晚安日记wanna5 小时前
大厂禁 JOIN 的真正原因,拆到第四层才清楚
数据库·后端·面试
java1234_小锋5 小时前
Redis 宣布正式接入 AI
数据库·人工智能·redis
这个DBA有点耶5 小时前
数据融合平台的下一代形态:数据库内核自己就能融合,为什么还要ETL?
数据库·架构·aigc
数据库小学妹5 小时前
MySQL大表怎么优化?2亿行表的分区归档与冷热分离实战
数据库·mysql·分库分表·分区表·数据库运维·冷热分离
91刘仁德5 小时前
RAG实战 - 向量数据库(Milvus)
数据库·milvus