【Linux】mount挂载问题案例

记录一次挂载问题,服务端共享路径已经显示出来,但客户端挂载就报下面的错误。

bash 复制代码
mount: wrong fs type, bad option, bad superblock on 172.16.11.11:/opt/file/yami-saas,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

查看dmesg日志

bash 复制代码
[root@5gprd-0002 opt]# dmesg | tail
Please review provided documentation for limitations.
[280692.137992] Bridge firewalling registered
[280692.357114] ctnetlink v0.93: registering with nfnetlink.
[280692.459219] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready
[285980.784924] FS-Cache: Loaded
[285980.825044] RPC: Registered named UNIX socket transport module.
[285980.825623] RPC: Registered udp transport module.
[285980.826045] RPC: Registered tcp transport module.
[285980.826486] RPC: Registered tcp NFSv4.1 backchannel transport module.
[285980.861059] FS-Cache: Netfs 'nfs' registered for caching
[root@5gprd-0002 opt]# cat /var/log/messages | grep mount
[root@5gprd-0002 opt]# 

问题原因是在服务器上没有安装nfs。

客户端安装yum -y install nfs-utils,问题解决,恢复正常挂载。

相关推荐
未济2 天前
linux 配置环境变量
linux
傲世仙尊2 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫2 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
_艾伦 耶格尔.2 天前
进程间通信
linux
AI职业加油站2 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
Liuqy-052 天前
Linux IO编程——静态库、动态库
linux
此冬歌咏2 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
彧azz2 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog2 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发