mysqldump导入备份数据到阿里云RDS会报错吗

前言

大家都知道,数据量小的备份都使用 mysqldump 命令来备份,最近本人从阿里云RDS实例备份博客数据,并再次把备份出来的数据导入到RDS实例时,会遇到错误 [Err] 1227 - Access denied; you need (at least one of) the SUPER privilege(s) for this operation。

PS:阿里云RDS实例版本:5.6

遇到上面错误感觉很奇怪,为什么没有权限写入,使用的账号是高级账号,为什么没有权限了???

错误原因

通过上面报错,查找阿里云帮助文档,最后找到答案,下面是具体解决方法。

  • 导入RDS MySQL 实例:SQL 语句中含有需要 Supper 权限才可以执行的语句,而 RDS MySQL不提供 Super 权限,因此需要去除这类语句。
  • 本地 MySQL 实例没有启用 GTID。

解决方法

1、去除 DEFINER 子句

检查 SQL 文件,去除下面类似的子句

bash 复制代码
DEFINER=`root`@`%` 

在 Linux 平台下,可以尝试使用下面的语句去除:

bash 复制代码
$ sed -e 's/DEFINER[ ]*=[ ]*[^*]*\*/\*/ ' your.sql > your_revised.sql

2、去除 GTID_PURGED 子句

检查 SQL 文件,去除下面类似的语句

bash 复制代码
SET @@GLOBAL.GTID_PURGED='d0502171-3e23-11e4-9d65-d89d672af420:1-373,
d5deee4e-3e23-11e4-9d65-d89d672a9530:1-616234';

在 Linux 平台,可以使用下面的语句去除

bash 复制代码
$ awk '{ if (index($0,"GTID_PURGED")) { getline; while (length($0) > 0) { getline; } } else { print $0 } }' your.sql | grep -iv 'set @@' > your_revised.sql

3、检查修改后的文件

修改完毕后,通过下面的语句检查是否合乎要求。

bash 复制代码
$ egrep -in "definer|set @@" your_revised.sql

如果上面的语句没有输出,说明 SQL 文件符合要求。

参考链接

🔥运维干货分享

相关推荐
workflower37 分钟前
汽车自动驾驶9 要素
人工智能·机器学习·重构·云计算·汽车·无人机
AliCloudROS10 小时前
计算巢 X DeepSeek Harness — 云端智能体工作台
人工智能·阿里云
阿乔外贸日记19 小时前
全球电子产业高度集中:中、韩、日和中国台湾地区占全球数字硬件产能八成
大数据·服务器·人工智能·物联网·云计算
ao-weilai21 小时前
MySQL数据库:用户管理
数据库·mysql·adb
mengge.cloud1 天前
Redis
运维·服务器·数据库·redis·缓存·云计算
酒神dnspup1 天前
多地区网站可用性监控怎么做?DNSPup 从基线到告警的完整实战
运维·ios·云计算·iphone·dns·网络监控
闲云野鹤在人间1 天前
MySQL|从理论、安装、备份到主从复制、MHA高可用详解
linux·运维·数据库·mysql·云计算
Gl�ria2 天前
MySQL 单机版 vs 高可用版:宕机排查 + 故障处理
mysql·adb·架构
钟祥哎眼2 天前
镜片膜层都是什么:加硬、减反射、疏水一次说清?/钟祥极博视科普
阿里云