如何在centos 中运行arm64程序

文章目录

前言

在云服务器安装程序过程中出现报错Exec format error无法启动arm64程序 可使用qemu解决问题

安装qemu

如果有apt的话可以直接安装
apt install qemu-user-static

如果是yum源的话是没有该工具的
可以直接下载预编译的QEMU静态二进制文件
wget https://github.com/multiarch/qemu-user-static/releases/download/v7.2.0-1/qemu-aarch64-static

添加执行权限

chmod +x qemu-aarch64-static

注册qemu的二进制格式支持

sudo systemctl restart systemd-binfm

将qemu-aarch64-static复制到系统PATH目录

sudo cp qemu-aarch64-static /usr/local/bin/

就可以使用了

相关推荐
g105655913919 分钟前
公有云_云运维服务
java·运维·服务器
码农小韩25 分钟前
Linux驱动理论(二)——Linux字符设备驱动
linux·嵌入式软件开发·linux操作系统·linux应用开发·linux驱动理论
well061232 分钟前
Linux粘滞位与Makefile机制深度解析
linux·运维·服务器
再写一行代码就下班40 分钟前
linux sh脚本在windows修改导致无法使用解决方式
java·linux·centos
hzxpaipai43 分钟前
杭州企业官网怎么建设?从策划到上线的5步建站方法
运维·服务器·前端·网络
哲霖软件1 小时前
非标机械设备公司怎么做信息化?破解通用ERP水土不服难题
大数据·运维
额额额对了1 小时前
SPI通信
linux·c语言·汇编·单片机·嵌入式硬件·arm
子木HAPPY阳VIP1 小时前
Ubuntu 关闭防火墙操作步骤
linux·运维·ubuntu
王振超wzc2 小时前
嵌入式开发环境搭建--WM软件安装,Ubuntu操作系统安装
linux·运维·ubuntu
AutumnWind04202 小时前
【Docker Compose 快速入门】
运维·docker·容器