ElasticSearch服务端报错:FileSystemException: No space left on device

一、确认问题

  1. elasticsearch节点启动失败

  2. elasticsearch节点集群日志中有类似如下报错

    bash 复制代码
    ElasticsearchException: java.nio.file.FileSystemException: /usr/share/elasticsearch/workspace/data/nodes/0/state/_13qo.fdt: No space left on device

二、处理办法

问题原因

  • 主机磁盘空间不足
  • 正常情况下ES自身是有磁盘水位线(cluster.routing.allocation.disk.watermark)的设置,存储数据目录在非人为解除只读情况下不会打满磁盘,需要确认导致磁盘打满的根本原因,大致有以下方向:
    1. 水位线达到阈值后触发集群只读,运维人员手动解除了只读
    2. 集群日志级别过低,并且没有配置好滚动策略导致日志无法滚动或保存日志数量过大
      3.与其他服务共用了一块存储,其他服务打爆了磁盘

处理办法

根据 问题原因 中指出的思路排查出问题根本原因并按照以下思路处理

  1. 删除磁盘上服务的日志类文件,给ES留出能正常运行的空间

  2. 节点能够正常启动后立即设置集群只读可删

    bash 复制代码
    curl -s -XPUT -H "Content-Type: application/json" es访问地址/_cluster/settings -d '{"persistent": {"cluster.blocks.read_only_allow_delete": true}}'
  3. 删除ES集群监控类索引

    bash 复制代码
    curl -s -XDELETE es访问地址/.monitoring-es*
  4. 给数据量大、按时间创建的索引设置生命周期,只保留一定期限内的数据,超过期限的删除,关于索引生命周期管理(ILM)可参考https://elasticstack.blog.csdn.net/article/details/102728987

  5. 若与其他服务共用磁盘,建议拆分开,避免服务之间相互干扰,增加运维难度

  6. 最后处理完磁盘空间问题后,需要取消集群只读的设置

    bash 复制代码
    ​curl -s -XPUT -H "Content-Type: application/json" es访问地址/_cluster/settings -d '{"persistent": {"cluster.blocks.read_only_allow_delete": null}}'
相关推荐
闲蛋小超人笑嘻嘻15 分钟前
Git Worktree 详解
大数据·elasticsearch·搜索引擎
Y38153266216 分钟前
行业动态周报:用新闻 API 追踪一个赛道的声音变化
python·搜索引擎
制造业的搬运工32 分钟前
车载 PCB 打样周期与选型指南:从 IATF 16949 到 IPC-6012 的 5 个硬指标
大数据·网络·人工智能·制造·pcb工艺
55873 生态系统33 分钟前
55873 正和博弈经济模型:重构数字时代商业价值体系
大数据·人工智能·重构·全域文明操作系统·55873 操作系统·55873全域文明生态体系
jqpwxt1 小时前
启点创新科技景区私有化票务管理系统:智慧景区数字化建设核心服务商,以本地部署筑牢景区数字化安全与稳定底座
大数据·人工智能·科技·云计算·旅游
2601_965742221 小时前
短视频脚本创作方法分享:本地生活类账号的起步思路
大数据·人工智能·算法·ai·新媒体运营·生活
MayBaymax1 小时前
Elasticsearch 原理与用法
java·elasticsearch
旋生万物1 小时前
素数螺旋映射 $z_n=n^{1+i}$ 的角分布统计检验与零模型对比
大数据·前端·人工智能·算法·云原生·螺旋生成论·螺旋相位
IT大白鼠1 小时前
搜索系列 · 第 01 篇——认知入门:Elasticsearch 是什么
elasticsearch·nosql
计算机源码社2 小时前
27届计算机毕设源码|基于Python的黄金价格特征分布与周期聚类可视化研究 基于大数据技术的黄金价格历史演变规律与波动特征研究
大数据·数据挖掘·数据分析