服务器安装操作系统报X or window manager startup failed, falling back to mode

一、现象

现在服务器上安装了nvidia的显卡,然后重新安装linux以及以linux为基础开发的其他操作系统,进入安装时,报X or window manager startup failed, falling back to mode,不能通过ui界面选择配置项,只能通过文字模式选择,即使使用文字模式安装成功了,后面有可能也会有其他问题,特别是跟ui相关的功能。

二、解决方法

进入选择安装时,一般会有

install......

test ......

(1)我们一般选择第一个install ......选项,不要回车,按下键盘的e键

(2)进入一个引导编辑界面,有一行的末尾有一个quiet,在这个单词的前面加上nomodeset,注意前后都有空格

bash 复制代码
...... nomodeset quiet

(3)按crtl+x,启动安装,这样就不会去使用nvidia显卡,即可正常显示ui界面安装

相关推荐
Apipi*2 小时前
30天速通Linux 第六章信号及信号处理
linux·运维·信号处理
天启HTTP3 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
广州浮点FLOATLIC6 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
BLUcoding6 小时前
接口服务公网超时排查记录:SecureRandom 阻塞问题分析与解决
java·linux·springboot·aes·securerandom
AIgorithmGEEK6 小时前
[Linux]从手写报头到内核套路:序列化、反序列化与自定义协议全链路
linux·运维·服务器·网络·序列化·反序列化
Nil2086 小时前
leetcode 139单词拆分
linux·运维·服务器
Starry-sky(jing)6 小时前
BUG: unable to handle kernel paging request 完整排查:dmesg 四要素与三路定罪
linux·运维·服务器·内核·排障
mounter6256 小时前
从硬件互连到操作系统变革:CXL 技术演进与 Linux 内核工程挑战
linux·运维·服务器
xh didida8 小时前
Linux -- 基础IO
linux·服务器·开发语言·c++
zly35009 小时前
centos7 mount设备挂载 /dev/sda1/硬盘挂载
linux·运维·服务器