整理安装ES和Logstash

1.安装elasticsearch

1.1.检查是否已经安装

开发环境之前安装了,检测失败的方法如下:

测试环境检查

结论,测试环境没有安装过ES

1.2.开始安装

准备使用开发环境已经安装的包。压缩安装包

传到新服务器对应目录,并解压

适配启动脚本start-es.sh

尝试启动:

再次检测

bash 复制代码
curl -X GET "localhost:9200"
bash 复制代码
ps -ef | grep elasticsearch

写一个关闭脚本

启动脚本如果遇到权限问题,设置:

bash 复制代码
chmod +x start-es.sh
chmod +x stop-es.sh

1.3.可能遇到的权限问题(本次安装没碰到,开发环境安装出现过)

没出现的原因,可能是这样文件拷贝过来都有了,然后使用的用户又一致

bash 复制代码
java.io.FileNotFoundException: /home/geit/midend-center/service/elasticsearch/logs/geit-es-cluster_server.json (权限不够)

需要的可选设置:

bash 复制代码
sudo chown -R geit:geit /home/geit/midend-center/service/elasticsearch
sudo chmod -R 755 /home/geit/midend-center/service/elasticsearch/logs/
mkdir -p logs
sudo chmod 777logs/

1.4.历史数据清理

清理核心数据目录:

清理日志和临时文件:

重置节点身份(防止集群冲突):

加test字样

bash 复制代码
cluster.name: geit-es-test-cluster
node.name: test-node-1

检查:

bash 复制代码
curl -X GET localhost:9200

1.5.系统资源检查

关注ES相关配置

-Xms8g (初始堆大小)

含义:Elasticsearch 启动时,立刻向操作系统申请 8GB 的内存。

-Xmx8g (最大堆大小)

含义:Elasticsearch 运行过程中,允许占用的最大内存是 8GB。如果超过这个限制,就会报错(OutOfMemoryError)并崩溃。

检查服务器资源是否足够:

启动ES状态

关闭ES状态

相关推荐
西木莉12 分钟前
大数据安全挑战升级:从隐私保护到信任构建
大数据
wtblszn14 分钟前
空压机在线监测物联网方案
大数据·运维·物联网·自动化·能源
IT古董37 分钟前
《FDE前沿部署工程师实战教程》29 - Enterprise AI Security:Agent安全体系设计
大数据·数据库·人工智能
喆星时瑜1 小时前
RStudio 数据清洗案例教程
大数据·数据库
卷毛迷你猪1 小时前
快速实验篇(B02)DWD 生产级升级
大数据·hive·hadoop
阿狗童鞋1 小时前
Elasticsearch实战指南
大数据·elasticsearch·搜索引擎
老A的AI实验室2 小时前
赛博月刊 #2026年9月
大数据·人工智能·深度学习·ai·llm
卷毛迷你猪2 小时前
快速实验篇(B03) 用户行为漏斗与转化率
大数据·hive·hadoop
IT大白鼠3 小时前
搜索系列 · 第 04 篇——部署实操:内网集群落地
运维·elasticsearch·nosql
径硕科技JINGdigital3 小时前
出海企业想要借助统一平台接入国际主流基础模型,可选哪些云上生成式 AI 平台?
大数据·人工智能