Dockerfile打镜像突然报错mkdir都不行了

使用 WORKDIR 来替代 RUN mkdir -p 创建目录

随后deployment找不到jar包位置了,改为绝对路径

随后configmap也不生效了,改为挂整个目录

挂载整个config目录,不要subPath,k8s会自动创建/apps/svr/config

相关推荐
H.莓飛6 小时前
【C++】命名空间、缺省参数、函数重载与引用
linux·开发语言·c++·visual studio
91刘仁德6 小时前
IP协议详解:从IP协议头到网段划分、路由与NAT
linux·服务器·网络·网络协议·tcp/ip
辻弋2016 小时前
五年前的旅行视频糊成马赛克?Video2X用Real-ESRGAN逐帧重建细节,但只支持Windows、集显用户建议直接放弃
服务器·数据库·windows·游戏引擎·电脑
硅基手札7 小时前
【Linux内核专栏 14】网络协议栈
linux·运维·网络协议
沫璃染墨8 小时前
《Linux工程实践篇(一):认识设计模式——从日志系统看策略模式》
linux·c++·安全·设计模式·策略模式
工作10年+,存储芯片行业9 小时前
Linux NVMe 中断排查与性能优化:CPU 亲和性
linux·运维·服务器·windows·性能优化·ssd·pcie
wuminyu9 小时前
ForkJoinPool内部WorkQueue的Lock-Free数组操作以及并发任务窃取原理剖析
java·linux·c语言·jvm·c++
快乐の番薯9 小时前
卷王问卷考试系统自动化功能测试
运维·功能测试·自动化
她说彩礼65万9 小时前
C语言 堆区和栈区
java·linux·c语言
一号弯9 小时前
装完LINUX,请先新建日常用户
linux·运维·服务器