云服务器elasticsearch环境搭建-单台

目录

[linux 安装包安装](#linux 安装包安装)

前置条件修改

修改配置

启动

[docker 安装](#docker 安装)

可能遇到的错误


云服务器elasticsearch环境搭建-集群-CSDN博客下载链接:Elastic Stack 软件的过往版本 | Elastic正在寻找 Elasticsearch、Logstash、Kibana、es-hadoop、Shield、Marvel 或我们的语言客户端的过往版本?配置服务器集群时,集群中节点数量没有限制,大于等于2个节点就可以看做是集群了。# 注意 集群生成环境在3台机器以上,这里使用1台机器来安装集群环境。问题:上面的jvm内存参数配置错误了,注意是-Xms。#配置集群间通信的端口号。https://blog.csdn.net/guo13313/article/details/166899598?sharetype=blogdetail&sharerId=166899598&sharerefer=PC&sharesource=guo13313&spm=1011.2480.3001.8118


You Know, for Search

Elastic --- The Search AI Company | ElasticPower insights and outcomes with The Elasticsearch Platform. See into your data and find answers that matter with enterprise solutions designed to help you accelerate time to insight. Try Elastic toda...https://www.elastic.co/

下载链接:Elastic Stack 软件的过往版本 | Elastic正在寻找 Elasticsearch、Logstash、Kibana、es-hadoop、Shield、Marvel 或我们的语言客户端的过往版本?您找对地方了。https://www.elastic.co/cn/downloads/past-releases#elasticsearch

linux 安装包安装

不能解压到root目录下, 如果已经在root下, 可以使用 mv移到 /opt/下

tar -zxvf elasticsearch-7.8.0-linux-x86_64.tar.gz

前置条件修改

elastic不能直接通过root用户启动(报错后面有),需要先创建一个普通用户

#创建用户

useradd user_es;

#设置密码

passwd user_es;

授权给新建用户

chown -R user_es /opt/elasticsearch-7.8.0

#用户+组 chown -R user_es:user_es /opt/elasticsearch-7.8.0

设置sudo权限

#使用root用户执行

visudo

或者 vim /etc/sudoers

#在root ALL=(ALL) ALL下面新增

user_es ALL=(ALL) ALL

修改普通用户打开文件次数限制

#编辑limits.conf文件

vi /etc/security/limits.conf

#添加以下内容

* soft nofile 65536

* hard nofile 131072

* soft nproc 2048

* hard nproc 4096

普通用户启动线程数限制

Centos6

vi /etc/security/limits.d/90‐nproc.conf

Centos7

vi /etc/security/limits.d/20‐nproc.conf

#添加以下内容

* soft nproc 4096

普通用户增大虚拟内存

vi /etc/sysctl.conf

#添加以下内容:

vm.max_map_count=262144

#保存后执行sysctl -p让配置生效

sysctl -p

执行完成后,重新打开终端。

修改配置

切换到普通用户user_es,修改elasticsearch.yml

su user_es
集群配置:

#集群名称

cluster.name: my-application

#节点名称

node.name: node-1 # 必须

#数据文件目录

path.data: ./data

#日志文件目录

path.logs: ./logs

#运行访问的网络,0.0.0.0表示任意ip都匹配,这样可以远程访问

network.host: 0.0.0.0# 必须

#http rest服务端口

http.port: 9200

#集群初始master选举节点

cluster.initial_master_nodes: "node-1" # 必须
单机配置

单机启动 关键配置,最后一行

discovery.type: single-node

#运行访问的网络,0.0.0.0表示任意ip都匹配,这样可以远程访问

network.host: 0.0.0.0

启动

#进入到bin目录(注意,不能使用root用户启动)

./elasticsearch -d

必须使用非root启动

su user_es

访问是否启动成功

浏览器访问

ip:9200

ps -ef | grep es

集群:

单机:

docker 安装

拉取镜像

docker pull docker.elastic.co/elasticsearch/elasticsearch:7.8.0

运行容器

docker run -p 9200:9200 \

-p 9300:9300 \

-e "discovery.type=single-node" \

-d --name elasticsearch \

docker.elastic.co/elasticsearch/elasticsearch:7.8.0

查看日志

内存不够用了,调整一下内存参数:

复制代码
# 运行容器
docker run -p 9200:9200 \
-p 9300:9300 \
-e "discovery.type=single-node" \
-e "ES_JAVA_OPTS=-Xms512m -Xmx512m" \
-d --name elasticsearch \
docker.elastic.co/elasticsearch/elasticsearch:7.8.0
安装IK分词器

https://github.com/medcl/elasticsearch-analysis-ik/releases/download/v7.8.0/elasticsearch-analysis-ik-7.8.0.ziphttps://github.com/medcl/elasticsearch-analysis-ik/releases/download/v7.8.0/elasticsearch-analysis-ik-7.8.0.zip

在 elastic目录下的plugins下新建ik文件夹

/opt/elasticsearch-7.8.0

mkdir ik

#在ik目录下解压elasticsearch-analysis-ik-7.8.0.zip文件

unzip elasticsearch-analysis-ik-7.8.0.zip

#删除zip文件

rm -f elasticsearch-analysis-ik-7.8.0.zip

重启es

./elasticsearch -d

测试安装

curl http://127.0.0.1:9200/_cat/plugins

#或

curl -XPOST http://127.0.0.1:9200/_analyze -H "Content-Type:application/json" -d '{

"analyzer":"ik_max_word",

"text":"我是中国人"

}'

附:可能遇到的问题

1、root启动,linux中通过包安装,root用户直接启动会失败,需要新建普通用户启动

2、解压后的elasticsearch-7.8.0不能放到/root/目录下,会有权限问题

3、elasticsearch.yml配置缺少关键配置,启动失败

4、服务器内存不够,启动直接失败:

调整启动参数即可

5、-bash: unzip: command not found:

缺少命令,安装一下即可:yum install -y unzip

相关推荐
Zhou1411361 小时前
CICD_01_持续集成与Jenkins入门
运维·ci/cd·jenkins
Elasticsearch1 小时前
使用 Jev 作为 search reranker:基准测试与实现方法
elasticsearch
硅基手札1 小时前
MCP 实战 —— 从零写一个 CRC16 服务器(保姆级)
运维·服务器·ai
今年下半年2 小时前
【运维】windows虚拟机安装arm(aarch64)服务器
运维·windows·arm·虚拟机·aarch64
杨云龙UP2 小时前
TDengine Community 超级表建表实战:统一21个TAG与DOUBLE/字符串数据模板
运维·服务器·数据库·时序数据库·tdengine·涛思数据·stable建表
高山有多高2 小时前
【Linux笔记】冯诺依曼体系结构
linux·运维·笔记
筑梦之路2 小时前
Alibaba Cloud Linux 4 IPXE全自动安装(直连官方源)——筑梦之路
linux·运维·服务器·国产化·阿里云操作系统
Pointer Pursuit3 小时前
make / Makefile
linux·运维·服务器
ZhangJun953 小时前
Linux常用命令笔记,中高级运维高频指令,并附上vim常见操作
linux·运维·centos·云计算·vim