每日打卡day9——差分矩阵

输入一个 n 行 m 列的整数矩阵,再输入 q 个操作,每个操作包含五个整数 x1,y1,x2,y2,c,其中 (x1,y1) 和 (x2,y2) 表示一个子矩阵的左上角坐标和右下角坐标。

每个操作都要将选中的子矩阵中的每个元素的值加上 c。

请你将进行完所有操作后的矩阵输出。

输入格式

第一行包含整数 n,m,q。

接下来 n 行,每行包含 m 个整数,表示整数矩阵。

接下来 q 行,每行包含 5 个整数 x1,y1,x2,y2,c表示一个操作。

输出格式

共 n 行,每行 m 个整数,表示所有操作进行完毕后的最终矩阵。

数据范围

1≤n,m≤1000

1≤q≤100000

1≤x1≤x2≤n

1≤y1≤y2≤m

−1000≤c≤1000

−1000≤矩阵内元素的值≤1000

输入样例:

复制代码
3 4 3
1 2 2 1
3 2 2 1
1 1 1 1
1 1 2 2 1
1 3 2 3 2
3 1 3 4 1

输出样例:

复制代码
2 3 4 1
4 3 4 1
2 2 2 2

代码如下:

cpp 复制代码
#include <iostream>
#include <vector>
using namespace std;

const int N = 1010;
    
int n, m, q;
int l1, r1, l2, r2, v;
vector<vector<int>> nums(N, vector<int>(N, 0));

void insert(int l1, int r1, int l2, int r2, int c){
    nums[l1][r1] += c;
    nums[l2 + 1][r1] -= c;
    nums[l1][r2 + 1] -= c;
    nums[l2 + 1][r2 + 1] += c;
}

int main(){
    cin >> n >> m >> q;

    for(int i = 1; i <= n; i++){
        for(int j = 1; j <= m; j++){
            int c = 0;
            cin >> c;
            insert(i, j, i, j, c);
        }
    }
    
    while(q--){
        cin >> l1 >> r1 >> l2 >> r2 >> v;
        insert(l1, r1, l2, r2, v);
    }
    
    for(int i = 1; i <= n; i++){
        for(int j = 1; j <= m; j++){
            nums[i][j] += nums[i - 1][j] + nums[i][j - 1] - nums[i - 1][j - 1];
        }
    }
    
    for(int i = 1; i <= n; i++){
        for(int j = 1; j <= m; j++){
            cout << nums[i][j] << " ";
        }
        puts(" ");
    }
    
    return 0;   
}
相关推荐
算AI9 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
我不会编程55510 小时前
Python Cookbook-5.1 对字典排序
开发语言·数据结构·python
懒羊羊大王&10 小时前
模版进阶(沉淀中)
c++
owde11 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
第404块砖头11 小时前
分享宝藏之List转Markdown
数据结构·list
GalaxyPokemon11 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi11 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh11 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大12 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it
A旧城以西12 小时前
数据结构(JAVA)单向,双向链表
java·开发语言·数据结构·学习·链表·intellij-idea·idea