PAT 1065 A+B and C (64bit)

个人学习记录,代码难免不尽人意。

Given three integers A, B and C in (−2^63^,2^63^), you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1). Each line should ends with '\n'.

Sample Input:

3

1 2 3

2 3 4

9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false

Case #2: true

Case #3: false

cpp 复制代码
#include<cstdio>
#include<iostream>
typedef long long LL;
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	bool ans[n]={false};
	for(int i=0;i<n;i++){
		LL a;
		LL b;
		LL c;
		LL res;
		cin >> a >> b >> c;
		int ap=a%10;
		int bp=b%10;
		int cp=c%10;
		res=(a/10)*10+(b/10)*10+ap+bp;
		if(res>(c/10)*10+cp) ans[i]=true;
		
		
	} 
	for(int i=0;i<n;i++){
		if(ans[i])printf("Case #%d: true\n",i+1);
		else printf("Case #%d: false\n",i+1);;
	}
}

因为longlong类型的存储范围为[-2^63^,2^63^),所以题目中部分数据可能会超出限制,因此我们需要处理这部分数据,我的想法是这样的,将原数据范围处理到[-2^62^,2^62^],然后再加上A/B/C末位数来判断。举个例子,比如A=13,B=5,C=23,相当于判断 10+3+5是否大于20+3,这样就避免了数据越界了。

而在《算法笔记》上的解法是根据计算机组成原理来解的,如果当两个正数相加等于负数或者两个负数相加等于正数的话就是越界。这样做也可以。

PS:我设置bool数组是当时觉得需要一次性输出所有结果,但现在看来在PTA上不需要这样。

相关推荐
Am心若依旧40935 分钟前
[c++11(二)]Lambda表达式和Function包装器及bind函数
开发语言·c++
明月看潮生37 分钟前
青少年编程与数学 02-004 Go语言Web编程 20课题、单元测试
开发语言·青少年编程·单元测试·编程与数学·goweb
大G哥1 小时前
java提高正则处理效率
java·开发语言
stm 学习ing1 小时前
HDLBits训练5
c语言·fpga开发·fpga·eda·hdlbits·pld·hdl语言
VBA63371 小时前
VBA技术资料MF243:利用第三方软件复制PDF数据到EXCEL
开发语言
轩辰~1 小时前
网络协议入门
linux·服务器·开发语言·网络·arm开发·c++·网络协议
小_太_阳1 小时前
Scala_【1】概述
开发语言·后端·scala·intellij-idea
向宇it1 小时前
【从零开始入门unity游戏开发之——unity篇02】unity6基础入门——软件下载安装、Unity Hub配置、安装unity编辑器、许可证管理
开发语言·unity·c#·编辑器·游戏引擎
古希腊掌管学习的神2 小时前
[LeetCode-Python版]相向双指针——611. 有效三角形的个数
开发语言·python·leetcode
赵钰老师2 小时前
【R语言遥感技术】“R+遥感”的水环境综合评价方法
开发语言·数据分析·r语言