链路聚合详解

链路聚合详解

华为交换机链路聚合:

java 复制代码
方式一:配置手工负载分担方式的链路聚合
[CORE1] interface Eth-Trunk 1
[CORE1-Eth-Trunk1] trunkport GigabitEthernet 0/0/5 to 0/0/6
[CORE1-Eth-Trunk1] port link-type access
[CORE1-Eth-Trunk1] port default vlan 300
[CORE1-Eth-Trunk1] quit
方式二:配置LACP模式的链路聚合
[CORE1] interface Eth-Trunk 1
[CORE1-Eth-Trunk1] mode lacp
[CORE1-Eth-Trunk1] trunkport GigabitEthernet 0/0/5 to 0/0/6
[CORE1-Eth-Trunk1] port link-type access
[CORE1-Eth-Trunk1] port default vlan 300
[CORE1-Eth-Trunk1] quit
# 在CORE1上配置系统优先级为100,使其成为LACP主动端

[CORE1] lacp priority 100
# 在CORE1上配置活动接口上限阈值为2

[CORE1] interface Eth-Trunk 1
[CORE1-Eth-Trunk1] max active-linknumber 2
[CORE1-Eth-Trunk1] quit
# 在CORE1上配置接口优先级确定活动链路(配置GE0/0/5和GE0/0/6为活动链路)

[CORE1] interface GigabitEthernet 0/0/5
[CORE1-GigabitEthernet0/0/5] lacp priority 100
[CORE1-GigabitEthernet0/0/5] quit
[CORE1] interface GigabitEthernet 0/0/6
[CORE1-GigabitEthernet0/0/6] lacp priority 100
[CORE1-GigabitEthernet0/0/6] quit

Linux链路聚合bond

java 复制代码
1、mode=0(balance-rr)(平衡抡循环策略)

2、mode=1(active-backup)(主-备份策略)

3、mode=2(balance-xor)(平衡策略,根据hash策略平衡)

4、mode=3(broadcast)(广播策略,高可靠较浪费资源)

5、mode=4(802.3ad)(IEEE 802.3ad 动态链接聚合)

6、mode=5(balance-tlb)(适配器传输负载均衡)

7、mode=6(balance-alb)(适配器适应性负载均衡)

配置

java 复制代码
cat /etc/sysconfig/network-scripts/ifcfg-p2p1
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
NAME=p2p1
DEVICE=p2p1
ONBOOT=yes
MASTER=bond0
SLAVE=yes

[root@dev2 ~]# cat /etc/sysconfig/network-scripts/ifcfg-p2p2
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
NAME=p2p2
DEVICE=p2p2
ONBOOT=yes
MASTER=bond0
SLAVE=yes

cat /etc/sysconfig/network-scripts/ifcfg-bond0 
DEVICE=bond0
NAME=bond0
TYPE=Bond
BONDING_MASTER=yes
IPADDR=192.168.1.2
PREFIX=24
GATEWAY=192.168.1.254
ONBOOT=yes
DNS1=8.8.8.8
BOOTPROTO=none
BONDING_OPTS="mode=4 miimon=100"

开机自动加载模块到内核
#echo 'alias bond0 bonding' >> /etc/modprobe.d/dist.conf
#echo 'options bonding mode=0 miimon=200' >> /etc/modprobe.d/dist.conf
#echo 'ifenslave bond0 eth0 eth1' >>/etc/rc.local
miimon=100

##查看bond0状态
cat /proc/net/bonding/bond0 
相关推荐
马立杰1 小时前
H3CNE-33-BGP
运维·网络·h3cne
云空2 小时前
《DeepSeek 网页/API 性能异常(DeepSeek Web/API Degraded Performance):网络安全日志》
运维·人工智能·web安全·网络安全·开源·网络攻击模型·安全威胁分析
没有名字的小羊3 小时前
Cyber Security 101-Build Your Cyber Security Career-Security Principles(安全原则)
运维·网络·安全
m0_465215793 小时前
TCP & UDP Service Model
服务器·网络·tcp/ip
千夜啊3 小时前
Nginx 运维开发高频面试题详解
运维·nginx·运维开发
存储服务专家StorageExpert4 小时前
答疑解惑:如何监控EMC unity存储系统磁盘重构rebuild进度
运维·unity·存储维护·emc存储
chian-ocean6 小时前
从理论到实践:Linux 进程替换与 exec 系列函数
linux·运维·服务器
敖行客 Allthinker6 小时前
从 UTC 日期时间字符串获取 Unix 时间戳:C 和 C++ 中的挑战与解决方案
linux·运维·服务器·c++
JunLan~6 小时前
Docker 部署 GLPI(IT 资产管理软件系统)
运维·docker·容器
norsd8 小时前
MongoDb user自定义 role 添加 action(collStats, EstimateDocumentCount)
服务器·数据库·mongodb