CentOS下多网卡绑定多IP段时导致只有一个会通的问题解决

CentOS下多网卡绑定多IP段时导致只有一个会通的问题解决

虚拟机配置多个网络地址,结果同时只能有一个ip是通的,

原因:Linux默认开启了反向路由检查导致的,比如说外面访问eth0的网卡,而网关在eth1上,又或者从eth0出的流量,而网关在eth1上,此时会检查到网关不在同一个网卡上导致出不去,进不来的问题。

解决方法:

关闭反向路由检查,配置如下,写入到/etc/rc.local开机启动执行

#经测试,下面几个文件没有写权限,执行后不生效

bash 复制代码
echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter 
echo 0 > /proc/sys/net/ipv4/conf/eth0/rp_filter 
echo 0 > /proc/sys/net/ipv4/conf/eth1/rp_filter 

或者写入到/etc/sysctl.conf

net.ipv4.conf.all.rp_filter = 0

net.ipv4.conf.eth0.rp_filter = 0

net.ipv4.conf.eth1.rp_filter = 0

注意:eth0、eth1是网卡名称,有些Linux操作系统网卡名称是 enp2s0f0、enp2s0f1、enp2s0f2、enp2s0f3等等

#使配置立即生效

bash 复制代码
sysctl -p
相关推荐
ai小陈7 小时前
深度学习CUDA异步报错定位:从错误堆栈到最小复现
运维·人工智能·深度学习·ai·gpu算力
北京恒星科通刘军7 小时前
灾害监测预警系统中,应急疏散广播的“应急叫应”实际送达率与有效性研究
网络·数据库·人工智能
Chill608 小时前
服务器home文件夹太小怎么把配置迁移到其他盘
运维·服务器
星恒随风8 小时前
Linux开发工具详解(一):软件包管理、Vim、GCC/G++、Makefile与进度条实战
linux·运维·笔记·学习·vim
TDengine (老段)8 小时前
集群从“能用“到“高可用“:副本、选主与故障切换到底怎么配
大数据·网络·数据库·物联网·oracle·时序数据库·tdengine
rest10248 小时前
做io测试
linux·服务器·网络
一条破秋裤8 小时前
Linux 网络编程基础:网络分类、分层模型与数据封装
linux·运维·网络
欣欣之王来了8 小时前
5G的行业应用:工业互联网、车联网、智慧医疗中的网络支撑
网络·学习·计算机网络·安全·教程
她说彩礼65万8 小时前
C语言 单引号与双引号
java·服务器·c语言
anew___8 小时前
《从零手写操作系统 (19):Ext2文件系统实战——从内存到磁盘的跨越》
java·服务器·前端·数据库·算法