x86平台运行arm64平台docker 镜像

    本文介绍在x86服务器上安装qemu-aarch64-statick仿真器,以实现x86服务器可以运行docker或docker-compose镜像。

报错信息:

x86服务器默认不能运行ARM平台镜像,会提示如下错误:

复制代码
	WARNING: The requested image's platform (linux/arm64/v8) does not match the detected host platform (linux/amd64) and no specific platform was requested

解决方法:

在x86服务器安装运行qemu-aarch64-statick,qemu-aarch64-statick是一个可以利用当前操作系统来运行其它架构的仿真器。

注:qemu-aarch64-statick方式模拟arm平台运行容器,性能较差,对性能要求较高的生成业务不建议使用。

一. 安装qemu-aarch64-statickd

复制代码
#下载qemu-aarch64-static
wget https://github.com/multiarch/qemu-user-static/releases/download/v5.2.0-1/qemu-aarch64-static

#移动并添加执行权限
cp qemu-aarch64-static /usr/bin/ 
chmod +x /usr/bin/qemu-aarch64-static

#注册qemu-user-static虚拟机,注:此命令是临时命令,服务器每次启动后都需要重新运行一次。
docker run --rm --privileged multiarch/qemu-user-static:register --reset

注册成功

二. 测试示例

2.1 docker运行arm平台容器

复制代码
#运行一个arm架构nginx
docker run -d --platform arm64 -p 80:80 -v /usr/bin/qemu-aarch64-static:/usr/bin/qemu-aarch64-static --name nginx-arm dockerproxy.com/library/nginx:latest

下面两个参数必选添加:

  • "--platform": 指定拉取ARM架构容器,默认拉取自己当前 CPU 平台的镜像。
  • "-v /usr/bin/qemu-aarch64-static:/usr/bin/qemu-aarch64-static " 启动容器时将 qemu-aarch64-static带入到容器

2.2 docker-compose运行arm平台容器

复制代码
# vi docker-compose.yml
version: '3'  
services:  
  nginx-arm:  
    image: dockerproxy.com/library/nginx:latest  
    platform: arm64       #指定容器运行的平台
    ports:  
      - 80:80  
    volumes:  
      - /usr/bin/qemu-aarch64-static:/usr/bin/qemu-aarch64-static   #启动容器时将 qemu-aarch64-static带入到容器

三. 系统架构查询方法

复制代码
#查看镜像使用的平台
docker inspect nginx:latest | grep -i 'architecture'

#查看容器使用的平台
docker run -t -v /usr/bin/qemu-aarch64-static:/usr/bin/qemu-aarch64-static nginx:latest uname -m

#查看本机使用的平台
uname -m
相关推荐
九皇叔叔7 小时前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技7 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese7 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky8 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南9 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123459 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人9 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender9 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly350010 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南10 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台