elasticsearch 索引write.lock报错解决 —— 筑梦之路

ES报错:

Caused by: org.apache.lucene.store.LockObtainFailedException: Lock held by another xxx write.lock

这是ES异常关闭导致索引的写锁未释放,索引一直处于red状态

解决方法:

  1. 停掉ES服务

  2. 找到相应的数据目录,找到对应的索引写锁文件write.lock所在位置,删除该文件

  3. 启动ES服务

如果有很多个索引都是该报错,可以使用批量处理的方法

批量处理方法:

  1. 停掉ES服务

  2. 进入数据目录:cd nodes/0/

  3. 查看写锁:find . -name write.lock > lock_list.txt

  4. 批量删除写锁

bash 复制代码
#!/bin/bash
# delete write.lock

for i in `cat lock_list.txt`
do
    rm -f $i
done
相关推荐
BJ_Bonree27 分钟前
博睿数据加入ITSS分会,成为国家级信息技术服务标准化体系单位成员!
大数据·运维·数据库·人工智能·可观测性
AgentMaster2 小时前
智能客服多渠道接入,5 款产品的全渠道整合能力对比与实战
大数据·人工智能·算法
程序员IT行业11 小时前
化工原料进销存安全管控数字化方案|解决危化品台账混乱、效期严控、分次发货溯源难题
大数据
Y38153266212 小时前
C# 调用谷歌搜索 API:HttpClient 与 System.Text.Json 实战
搜索引擎·.net
CNSSIRD数据库14 小时前
中国企业环境信用数据库2003-2026
大数据·数据库·数据分析·论文笔记
大大大大晴天14 小时前
每天认识一个组件:数据集成Apache SeaTunnel
大数据
广州宏帝箱包15 小时前
出口箱包的包装标准:防潮、防摔、运输安全的设计要点
大数据·网络
Geeys15 小时前
拼多多新店起流玩法:免费流量打底+付费流量爆发
大数据
日常筹谋记15 小时前
自动化仓储安全防护工况评估:明治传感器AS-33C技术适配性分析
大数据·运维·创业创新·业界资讯
updayday85415 小时前
离职域账号状态变更与Ping64操作记录核对
大数据·网络·数据库·安全·智能路由器