Word Power S

题目描述

约翰想要计算他那N(l < =N <= 1000)只奶牛的名字的能量.每只奶牛的名字由不超过1000个字 符构成,没有一个名字是空字体串.

约翰有一张"能量字符串表",上面有M(1 < =M < =100)个代表能量的字符串.每个字符串 由不超过30个字体构成,同样不存在空字符串.一个奶牛的名字蕴含多少个能量字符串,这个名 字就有多少能量.所谓"蕴含",是指某个能量字符串的所有字符都在名字串中按顺序出现(不 一定一个紧接着一个).

所有的大写字母和小写字母都是等价的.比如,在贝茜的名字"Bessie"里,蕴含有"Be" "si" "EE"以及"Es"等等字符串,但不蕴含"Ls"或"eB" .请帮约翰计算他的奶牛的名字 的能量.

输入格式

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains a string that is the name of the ith cow

* Lines N+2..N+M+1: Line N+i+1 contains the ith good string

输出格式

* Lines 1..N+1: Line i+1 contains the number of quality points of the ith name

样例输入

复制代码
5 3 
Bessie 
Jonathan 
Montgomery 
Alicia 
Angola 
se 
nGo 
Ont 

样例输出

复制代码
1 
1 
2 
0 
1 

参考代码

cpp 复制代码
#include <bits/stdc++.h>
#include <cstdio>
#define ll long long
using namespace std;

string s[1005];
string gs[105];
int ans[1005] = {0};

string lower(string s)
{
	string str = "";
	for(int i = 0; i < s.length(); i++)
	{
		if(s[i] >= 'A' && s[i] <= 'Z')
			str += s[i] + 32;
		else
			str += s[i];
	}
	
	return str;
}

int main()
{
	int n, m, v = 0;
	cin>>n>>m;
	
	for(int i = 1; i <= n; i++)
	{
		cin>>s[i];
		s[i] = lower(s[i]);
	}
	
	for(int i = 1; i <= m; i++)
	{
		cin>>gs[i];
		gs[i] = lower(gs[i]);
	}
	
	for(int i = 1; i <= n; i++)
	{
		bool flag = false;
		
		for(int t = 1; t <= m; t++)
		{
			int sh = -1;
			for(int j = 0; j < gs[t].length(); j++)
			{
				int kk = s[i].find(gs[t][j], sh+1); 
				if(kk <= sh)
				{
					flag = true;
					break;
				}
				sh = kk;
			}
			
			if(!flag)
			{
				ans[i]++;
			}
			flag = false;
		}
	}
	
	for(int i = 1; i <= n; i++)
	{
		cout<<ans[i]<<endl;
	}
	
	return 0;
}
相关推荐
香菜大丸7 分钟前
链表的归并排序
数据结构·算法·链表
jrrz08287 分钟前
LeetCode 热题100(七)【链表】(1)
数据结构·c++·算法·leetcode·链表
oliveira-time19 分钟前
golang学习2
算法
咖啡里的茶i23 分钟前
Vehicle友元Date多态Sedan和Truck
c++
海绵波波10729 分钟前
Webserver(4.9)本地套接字的通信
c++
@小博的博客35 分钟前
C++初阶学习第十弹——深入讲解vector的迭代器失效
数据结构·c++·学习
南宫生1 小时前
贪心算法习题其四【力扣】【算法学习day.21】
学习·算法·leetcode·链表·贪心算法
爱吃喵的鲤鱼2 小时前
linux进程的状态之环境变量
linux·运维·服务器·开发语言·c++
懒惰才能让科技进步2 小时前
从零学习大模型(十二)-----基于梯度的重要性剪枝(Gradient-based Pruning)
人工智能·深度学习·学习·算法·chatgpt·transformer·剪枝
7年老菜鸡2 小时前
策略模式(C++)三分钟读懂
c++·qt·策略模式