运维学习CentOS 7进行Nightingale二进制部署

.因为Nightingale需要MySQL保存一些数据,所以可以参考《CentOS 7.6使用mysql-8.0.31-1.el7.x86_64.rpm-bundle.tar安装Mysql 8.0》部署MySQL。
https://github.com/ccfos/nightingale/releases是可以github上下载Nightingale二进制安装包。

https://n9e.github.io/docs/install/binary/是二进制部署的说明。

nohup wget https://github.com/ccfos/nightingale/releases/download/v6.1.0/n9e-v6.1.0-linux-amd64.tar.gz &下载文件,下载完成会显示。

ps -aux | grep 13094只有一条消息,并且tail -n 3 nohup.out有'n9e-v6.1.0-linux-amd64.tar.gz' saved [43411688/43411688]这样的字样显示,就表明已经下载完成。

mkdir /opt/n9e && tar -zxf n9e-v6.1.0-linux-amd64.tar.gz -C /opt/n9e创建一个/opt/n9e目录,并把相关文件解压到/opt/n9e里边。

chmod 700 /opt/n9e把读写执行权限赋予文件属主。

cd /opt/n9e进入到目录里边。

mysql -ugooduser -pGood#1103 < n9e.sql初始化MySQL数据库里边数据。

nohup ./n9e &> n9e.log &后台运行。

ss -tlnp|grep 17000查看一下监控端口状态,发现没有数据,说明nohup ./n9e &> n9e.log &没有执行成功。

cat n9e.log看一下错误原因,发现如下:

bash 复制代码
[error] failed to initialize database, got error Error 1045: Access denied for user 'root'@'localhost' (using password: YES)
2023/09/16 18:02:58 main.go:36: failed to initialize: Error 1045: Access denied for user 'root'@'localhost' (using password: YES)

/opt/n9e/etc/config.toml第86行内容改为DSN="gooduser:Good#1103@tcp(127.0.0.1:3306)/n9e_v6?charset=utf8mb4&parseTime=True&loc=Local&allowNativePasswords=true"。

安装Redis

参考【滴滴开源运维监控系统】夜莺V5版本部署实践安装Redis。
sudo rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm安装yum源。

sudo yum --enablerepo=remi install redis-5.0.3

/usr/lib/systemd/system/redis.service里边的内容如下:

bash 复制代码
[Unit]
Description=Redis persistent key-value database
After=network.target
After=network-online.target
Wants=network-online.target

[Service]
ExecStart=/usr/bin/redis-server /etc/redis.conf --supervised systemd
ExecStop=/usr/libexec/redis-shutdown
Type=notify
User=redis
Group=redis
RuntimeDirectory=redis
RuntimeDirectoryMode=0755

[Install]
WantedBy=multi-user.target

systemctl enable redis允许redis开机自启动。

sed -i '/^# requirepass/a\requirepass GoodLearn#3' /etc/redis.conf在以# requirepass开头的内容下一行插入requirepass GoodLearn#3。

cat -n /etc/redis.conf | grep requirepass查看一下上边插入情况。

systemctl start redis开启redis,systemctl status redis可以看到redis的状态是active (running)。

nohup /opt/n9e/n9e &>> /opt/n9e/n9e.log &后台运行,ss -tlnp|grep 17000查看一下监控端口状态,发现输出了[1]+ Exit 1 nohup /opt/n9e/n9e &>>/opt/n9e/n9e.log,这样的话,就是没有启动成功。

sed -i 's/# Password = ""/Password = "GoodLearn#3"/g' /opt/n9e/etc/config.toml把# Password = ""替换成Password = "GoodLearn#3"。

安装VictoriaMetrics

参考《【夜莺监控】初识夜莺,强!》和《夜莺监控V6初探》安装VictoriaMetrics。
wget https://github.com/VictoriaMetrics/VictoriaMetrics/releases/download/v1.90.0/victoria-metrics-linux-amd64-v1.90.0.tar.gz下载时序库。

mkdir /opt/victoria-metrics创建目录。

tar xf victoria-metrics-linux-amd64-v1.90.0.tar.gz -C /opt/victoria-metrics/进行解压。

nohup /opt/victoria-metrics/victoria-metrics-prod &>> /opt/victoria-metrics/victoria.log &启动victoria-metrics-prod。

ps -aux | grep victoria-metrics-prod有两条数据,说明正常启动。

sed -i 's#9090/api/v1/write#8428/api/v1/write#g' /opt/n9e/etc/config.toml把9090/api/v1/write改成8428/api/v1/write。

此文章为10月Day 21学习笔记,内容来源于极客时间《运维监控系统实战笔记》。

相关推荐
虎头金猫3 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
AI职业加油站3 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏3 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
-梅3 天前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren3 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼3 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘3 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境
懂软件的胡子个哥3 天前
微信机器人为什么需要“回复候选”而不是所有 AI 内容直接发送
运维·微信·自动化·wechatapi·个人微信号二次开发
云贝贝贝3 天前
腾讯云 TDSQL(MySQL 版)性能优化与慢查询排障实战 6 招
运维·腾讯云
Lsetea3 天前
证书没到期却报certificate has expired:OpenSSL定位中间证书与系统时间
运维·https·ssl证书·openssl·证书链