Cisco配置RIP路由

动态路由分类

RIP简介

  • RIP是应用及开发较早的路由协议,是典型的距离矢量路由协议
  • 适用于小型网络,最大跳数15跳(16跳视为不可达)
  • RIP是基于UDP的,使用端口号520
  • 在CISCO IOS平台上的管理性距离为120

RIP各个版本的区别

实验拓扑

初始配置

配置R1各个接口IP

sh 复制代码
Router>enable 
Router#configure terminal 
Router(config)#hostname R1

R1(config)#interface e0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown 

R1(config-if)#interface e0/1
R1(config-if)#ip address 192.168.1.254 255.255.255.0
R1(config-if)#no shutdown 

配置R2各个接口IP

sh 复制代码
Router>enable 
Router#configure terminal 
Router(config)#hostname R2
R2(config)#

R2(config)#interface e0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown 

R2(config-if)#interface e0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown 

配置R3各个接口IP

sh 复制代码
Router>enable 
Router#configure terminal 
Router(config)#hostname R3
R3(config)#

R3(config)#interface e0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown 

R3(config-if)#interface e0/1
R3(config-if)#ip address 192.168.3.254 255.255.255.0
R3(config-if)#no shutdown

配置Vpc4和vpc5的ip

sh 复制代码
VPCS> ip 192.168.1.2/24 192.168.1.254
Checking for duplicate address...
VPCS : 192.168.1.2 255.255.255.0 gateway 192.168.1.254
sh 复制代码
VPCS> ip 192.168.3.2/24 192.168.3.254
Checking for duplicate address...
VPCS : 192.168.3.2 255.255.255.0 gateway 192.168.3.254

配置RIP

在R1上配置RIP并宣告网络

sh 复制代码
# 启动RIP进程
R1(config)#router rip 

# 选择版本2
R1(config-router)#version 2

# 宣告指定指定的直连网络(接口)
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.12.0

在R2上配置RIP并宣告网络

sh 复制代码
R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0

在R3上配置RIP并宣告网络

sh 复制代码
R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#network 192.168.23.0
R3(config-router)#network 192.168.3.0

查看路由

在R1上查看路由

sh 复制代码
R1#show ip route 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/1
L        192.168.1.254/32 is directly connected, Ethernet0/1
R     192.168.3.0/24 [120/2] via 192.168.12.2, 00:00:13, Ethernet0/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Ethernet0/0
L        192.168.12.1/32 is directly connected, Ethernet0/0
R     192.168.23.0/24 [120/1] via 192.168.12.2, 00:00:13, Ethernet0/0

可以看到R1学习到了192.168.3.0/24和192.168.23.0/24网段的路由

在R2上查看路由

sh 复制代码
R2# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.1.0/24 [120/1] via 192.168.12.1, 00:00:08, Ethernet0/0
R     192.168.3.0/24 [120/1] via 192.168.23.3, 00:00:17, Ethernet0/1
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Ethernet0/0
L        192.168.12.2/32 is directly connected, Ethernet0/0
      192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.23.0/24 is directly connected, Ethernet0/1
L        192.168.23.2/32 is directly connected, Ethernet0/1

可以看到R2学习到了192.168.1.0/24和192.168.3.0/24网段的路由

在R3上查看路由

sh 复制代码
R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

R     192.168.1.0/24 [120/2] via 192.168.23.2, 00:00:03, Ethernet0/0
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, Ethernet0/1
L        192.168.3.254/32 is directly connected, Ethernet0/1
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:03, Ethernet0/0
      192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.23.0/24 is directly connected, Ethernet0/0
L        192.168.23.3/32 is directly connected, Ethernet0/0

可以看到R3学习到了192.168.1.0/24和192.168.12.0/24网段的路由

ping测试

在vpc4上ping vpc5

sh 复制代码
VPCS> ping 192.168.3.2

84 bytes from 192.168.3.2 icmp_seq=1 ttl=61 time=1.202 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=61 time=0.751 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=61 time=0.916 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=61 time=0.743 ms
84 bytes from 192.168.3.2 icmp_seq=5 ttl=61 time=0.834 ms
相关推荐
刘若水1 小时前
Linux: 进程信号初识
linux·运维·服务器
阳小江2 小时前
Docker知识点
运维·docker·容器
只是橘色仍温柔3 小时前
xshell可以ssh连接,但vscode不行
运维·vscode·ssh
IT里的交易员3 小时前
【系统】换硬盘不换系统,使用WIN PE Ghost镜像给电脑无损扩容换硬盘
运维·电脑
共享家95273 小时前
深入剖析Linux常用命令,助力高效操作
linux·运维·服务器
大刘讲IT3 小时前
制造业数字化转型:流程改造先行还是系统固化数据?基于以MTO和MTS的投资回报分析
运维·经验分享·生活·产品经理·数据可视化
吃旺旺雪饼的小男孩4 小时前
Ubuntu 22.04 安装和运行 EDK2 超详细教程
linux·运维·ubuntu
阿政一号4 小时前
Linux进程间通信:【目的】【管道】【匿名管道】【命名管道】【System V 共享内存】
linux·运维·服务器·进程间通信
方渐鸿4 小时前
【2025】快速部署安装docker以及项目搭建所需要的基础环境(mysql、redis、nginx、nacos)
java·运维·docker·持续部署·dockercompse
小哈里4 小时前
【运维】云计算的发展历程,云原生时代的运维理念&工具技术栈,高可用系统的云运维 —— 以K8S集群调度算法与命令为例
运维·云原生·kubernetes·云计算·架构设计