Linux系统下安装RabbitMQ超简单教程(非详细)(Centos8)

文章目录

一、下载所需安装包

二、安装

  • 把文件上传到服务器目录,然后进入到那个目录运行命令即可
shell 复制代码
yum install -y socat
shell 复制代码
rpm -ivh erlang-25.3.2.7-1.el9.x86_64.rpm --nodeps --force
shell 复制代码
rpm -ivh rabbitmq-server-3.12.8-1.el8.noarch.rpm --nodeps --force

三、启动rabbitmq

  • 启动rabbitmq
shell 复制代码
systemctl start rabbitmq-server
  • 设置rabbitmq服务开机自启动
shell 复制代码
systemctl enable rabbitmq-server
  • 查看rabbitmq状态
shell 复制代码
systemctl status rabbitmq-server
  • 打开RabbitMQWeb管理界面插件
shell 复制代码
rabbitmq-plugins enable rabbitmq_management
  • 重启rabbitmq
shell 复制代码
systemctl restart rabbitmq-server
  • 关闭rabbitmq
shell 复制代码
systemctl stop rabbitmq-server

四、添加远程用户

  • 添加用户test,密码1111
shell 复制代码
rabbitmqctl add_user test 1111
  • 设置用户角色,分配操作权限
shell 复制代码
rabbitmqctl set_user_tags test administrator
  • 为用户添加资源权限(授予访问虚拟机根节点的所有权限)
shell 复制代码
rabbitmqctl set_permissions -p / test ".*" ".*" ".*"

五、图形化访问

  • ip:15672(这个地址)

六、修改rabbitmq的启动端口和管理端口(没有这个需求就不用看了)

  • rabbitmq安装完成了之后会自动创建/etc/rabbitmq文件夹,直接进入就完事了
  • rabbitmq会默认读取/etc/rabbitmq文件夹下的rabbitmq.config文件,如果没有这个文件则自己创建即可
  • tcp_listeners表示监听端口(这里设置为35672),是给你的程序使用的
  • rabbitmq_management表示管理端口(这里设置为45672),是给人使用的,也就是图形化界面
txt 复制代码
[ {
  rabbit,
  [ {
    tcp_listeners,
    [ {"0.0.0.0" ,35672}]
  }]
},{
  rabbitmq_management,
  [ {
    listener,
    [
      {port , 45672},
      {ip , "0.0.0.0"},
      {ssl,false}
    ]
  }]
}].
  • 重启rabbitmq即可生效

七、需要注意版本问题

  • CentOS的版本,不按照版本将会报错。erlang和rabbitmq都要符合下面的要求
    el6:CentOS 6.x 的下载
    el7:CentOS 7.x 的下载
    el8:CentOS 8.x 的下载
  • erlang需要和rabbitmq版本匹配
    版本对照表

可能遇到的错误和解决方式

version `GLIBC_2.34' 类型错误

  • 错误原文
txt 复制代码
/lib64/libc.so.6: version `GLIBC_2.34' not found (
  • 错误原因:erlang版本和centos版本不匹配导致

undefined function rabbitmqctl_escript:main类型错误

  • 错误原文
txt 复制代码
escript: exception error: undefined function rabbitmqctl_escript:main/1
  • 错误原因:erlang版本和rabbitmq版本不匹配导致

Job for rabbitmq-server.service failed 错误

  • 执行命令
shell 复制代码
systemctl start rabbitmq-server
  • 错误原文
txt 复制代码
Job for rabbitmq-server.service failed because the control process exited with error code.
  • 错误原因:rabbitmq版本和centos版本不匹配导致

参考文档

相关推荐
程序员-Benothing7 小时前
Vim编辑器从入门到精通:模式、快捷键、配置、插件
linux·运维·服务器
‎ദ്ദിᵔ.˛.ᵔ₎8 小时前
linux 进程信号 (上)
linux·服务器
15Moonlight8 小时前
Linux网络(02):Socket 编程 UDP
linux·网络·udp
此时不提桶,更待何时8 小时前
06-18-A-RabbitMQ消息特性与消费机制详解
分布式·rabbitmq
wuminyu8 小时前
ForkJoinPool窃取线程在扫描其他WorkQueue时的随机采样算法与Phase线程挂起唤醒机制解析
java·linux·c语言·jvm·c++
liulilittle9 小时前
Linux 下 select 测试函数
linux·服务器·网络·数据库·c++·select·c
DongQiShanRen9 小时前
玄龙(上):TICK 主循环——意识心跳怎么跳
linux·jvm·数据库·人工智能·数据挖掘·rust
小此方9 小时前
Linux网络(二十一):深入理解 TCP 异常处理:网线断开、Keepalive 保活机制与 Linux 内核传输层协议源码剖析
linux·网络·tcp/ip
pride.li9 小时前
Python 安装
linux·python·ubuntu
笔墨登场说说9 小时前
centos 8 使用 kafka_2.13-4.3.1.tgz 安装kafka
linux·kafka·centos