解决Kibana初始化失败报错: Unable to connect to Elasticsearch

现象:

原因: docker run生成容器的时候,指定elastic server时指向了localhost

为什么不能是localhost, 因为这个localhost指向的是容器本身的网络,而elastic用的是物理网络,两个网络是隔离的,所以如果kibana指向localhost:9200是没法访问到elastic的

解决办法: 生成docker容器时,将指向elastic server的ip指向宿主机的物理ip.

docker run -dt --name kibana-6.8.12 --restart=always -e ELASTICSEARCH_URL=http://192.168.10.82:9200 -p 5601:5601 kibana:6.8.12

或者使用docker-compose, 通过networks字段将两个容器绑定到同一个网络中

复制代码
version: '3'

services:
  elasticsearch:
    image: docker.elastic.co/elasticsearch/elasticsearch:6.8.12
    container_name: elasticsearch
    networks:
      - elastic-network
    ports:
      - "9200:9200"
      - "9300:9300"
    environment:
      - discovery.type=single-node

  kibana:
    image: docker.elastic.co/kibana/kibana:6.8.12
    container_name: kibana
    networks:
      - elastic-network
    ports:
      - "5601:5601"
    environment:
      - ELASTICSEARCH_URL=http://elasticsearch:9200

networks:
  elastic-network:
    driver: bridge

问题解决:

相关推荐
吴声子夜歌1 小时前
Docker入门与实战——实战案例(Web服务与应用)
docker·容器
Wang's Blog1 小时前
Java 项目部署之 Docker工具快速入门: Docker 架构拆解:镜像、容器、守护进程与 Registry
java·docker·架构
java_logo2 小时前
Docker 部署 OpenViking:轻松搭建 AI Agent 上下文数据库平台
数据库·人工智能·docker·agent·火山引擎·openviking·轩辕镜像
a5986522 小时前
Docker云手机搭建挂机环境,外网远程访问完整实操
docker·容器·智能手机·云手机
夜之眷属2 小时前
服务启动即崩:InetAddress.getLocalHost() 抛 UnknownHostException 排查记
java·运维·后端·docker
大圣编蚕2 小时前
OpenGL ES 教程:从零开始掌握 3D 渲染
大数据·elasticsearch·3d
郭老二3 小时前
【docker】使用阿里云的容器镜像服务(ACR)构建自己的容器仓库
阿里云·docker·容器
回眸不遇3 小时前
Elasticsearch嵌套类型nested使用指南<第七十二篇>
大数据·elasticsearch·jenkins
Wang's Blog6 小时前
Java 项目部署之 Docker工具快速入门: Docker 是什么以及它如何解决部署环境问题
java·开发语言·docker
AIGC大时代7 小时前
LLM Agent 执行沙箱闸门:失败含义与当天最小实验
docker·沙箱·闸门·bubblewrap·llm agent