字符串的旋转
左旋(逆时针)
示例:abcd------>bcda
右旋(顺时针)
示例:abcd------>dabc
例:
输入若干个字符串(1≤长度≤1000)右旋转串后的n(-长度≤n≤长度)个字符转移到字符串的首部。
|------|---|---|---|
| 题干 | 输入若干个字符串(1≤长度≤1000)右旋转串后的n(-长度≤n≤长度)个字符转移到字符串的首部。 如输入"abcdefg"和数字 2,右旋转 2 位得到的结果"fgabcde"。 输入"abcdefg"和数字 -2,右旋转 2 位得到的结果"cdefgab"。 第一行输入整数 N,表示测试数据的组数,之后输入N行测试数据。 |||
| 输入样例 | 3 abcdefg 2 abcdefg -2 abcdefg 5 |||
| 输出样例 | fgabcde cdefgab cdefgab |||
代码:
cpp
#include<stdio.h>
#include<string.h>
int main() {
char a[15]={0}, b[15];
int i, m;
size_t len;
scanf("%s%*c%d", a, &m);
len = strlen(a);
i = 0;
while (a[i] != '\0') {
b[(i + m + len) % len] = a[i];
i++;
}
b[i] = '\0';
printf("%s\n", b);
return 0;
}
左旋时while循环中的条件发生改变,及m变为负,故添加了+len及%len的操作。
总计这是目前最简单的方法
有更加难其精巧的方法见博客:
其中的方法需要花更长时间去理解,并且需要反复在反复不能一蹴而就。
后续会更新关于蓝桥杯的知识。