Web server failed to start. Port 8888 was already in use.

端口占用

强制终止占用端口的进程

  1. 获取占用端口的进程ID(PID):在终端或命令提示符中运行以下命令以查找占用端口的进程ID:

    ①在 Unix/Linux/Mac 上:lsof -i :8888

    ②在 Windows 上:netstat -ano | findstr :8888

    记下显示的进程ID。

  2. 强制终止进程:根据您的操作系统,可以使用以下命令来强制终止进程:

    ① 在 Unix/Linux/Mac 上,使用 kill -9 <PID> 命令,将 <PID> 替换为占用端口的进程ID。

    ②在 Windows 上,使用 taskkill /F /PID <PID> 命令,将 <PID> 替换为占用端口的进程ID。

相关推荐
步行cgn8 小时前
Spring c 命名空间注入详解
java·后端·spring
明月_清风8 小时前
Maven 到底是什么?一篇文章搞懂 Java 项目构建与依赖管理
java·后端·maven
aramae9 小时前
MySQL复合查询(8)
java·c语言·开发语言·后端·算法
Rain的Java大神之路9 小时前
如何快速上传10G文件
java·spring boot·redis·后端·mysql·spring cloud·面试
Wang's Blog10 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog10 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
Ivanqhz10 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
qq_25183645711 小时前
springboot vue3 开发实现 拼豆管理系统
java·开发语言·ai编程
caoerzhong11 小时前
JeeWMS 开源仓库管理系统全景解读:一套 Java WMS 如何把 WMS/OMS/BMS/TMS 装进同一个系统
java·开源
曹牧12 小时前
Java集合框架:List、ArrayList、Map 和 HashMap
java