Web server failed to start. Port 8888 was already in use.

端口占用

强制终止占用端口的进程

  1. 获取占用端口的进程ID(PID):在终端或命令提示符中运行以下命令以查找占用端口的进程ID:

    ①在 Unix/Linux/Mac 上:lsof -i :8888

    ②在 Windows 上:netstat -ano | findstr :8888

    记下显示的进程ID。

  2. 强制终止进程:根据您的操作系统,可以使用以下命令来强制终止进程:

    ① 在 Unix/Linux/Mac 上,使用 kill -9 <PID> 命令,将 <PID> 替换为占用端口的进程ID。

    ②在 Windows 上,使用 taskkill /F /PID <PID> 命令,将 <PID> 替换为占用端口的进程ID。

相关推荐
一 乐3 小时前
动漫书销售商城|基于springboot + vue动漫书销售商城(源码+数据库+文档)
java·数据库·vue.js·spring boot·毕业设计
卓怡学长4 小时前
w214基于jsp知道特产网
java·intellij-idea
步行cgn4 小时前
Spring 注解使用详解
java·spring
一条小小yu4 小时前
Spring IoC的理解
java·后端·spring
落魄实习生4 小时前
Agent Scope Java 2.x 系列【7】工具使用
java·开发语言·ai
旺仔学长 哈哈4 小时前
springboot钓鱼爱好者交流平台APP设计与实现
java·spring boot·mysql·充电桩管理系统
自强的小白6 小时前
核心功能(Service接口)
java·mybatis
乌暮7 小时前
深入理解 Java 泛型:把「万能盒子」用对、用稳
java·开发语言·后端·学习
大猫和小黄7 小时前
深入理解 Java Optional:从设计哲学到工程实战
java