Web server failed to start. Port 8888 was already in use.

端口占用

强制终止占用端口的进程

  1. 获取占用端口的进程ID(PID):在终端或命令提示符中运行以下命令以查找占用端口的进程ID:

    ①在 Unix/Linux/Mac 上:lsof -i :8888

    ②在 Windows 上:netstat -ano | findstr :8888

    记下显示的进程ID。

  2. 强制终止进程:根据您的操作系统,可以使用以下命令来强制终止进程:

    ① 在 Unix/Linux/Mac 上,使用 kill -9 <PID> 命令,将 <PID> 替换为占用端口的进程ID。

    ②在 Windows 上,使用 taskkill /F /PID <PID> 命令,将 <PID> 替换为占用端口的进程ID。

相关推荐
小羊没烦恼!19 小时前
微服务化的基石——持续集成
java·大数据·word·powerpoint·.net
俊昭喜喜里20 小时前
java中的继承和多态的区别
java
小羊没烦恼!20 小时前
初探性能优化——2个月到4小时的性能提升
java·开发语言·windows·算法·c#
譕痕20 小时前
JSONObject与JSONArray封装数据格式区别
java·json
胡写代码20 小时前
别再前后端各写一套表单校验了
java·后端
小鱼能吃糖20 小时前
缺陷修复总览 · mall电商项目:5类缺陷,1个病根,4个业务域
java·电商
此时不提桶,更待何时20 小时前
01-06-A-JVM排查实战详解
java·jvm
vipxieliang21 小时前
ValidX 在 DDD 领域驱动设计中的实践
java·spring boot
ba_pi21 小时前
mysql 查询所有表名并授权
java
ProcessOn官方账号21 小时前
java函数式编程--入门基础
java·编程·函数式编程