es7.13.2集群安装失败报错处理

ERROR: 2 bootstrap checks failed.You must address the points described in the following 2 lines before starting Elasticsearch.

bootstrap checks failed 1 of 2: memory locking requested for elasticsearch process but memory is not locked

bootstrap checks failed 1 of 2: max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

ERROR: Elasticsearch did not exit normally - check the logs at /a/es/logs/my-cluster.log

系统:centos7.6 (vm虚拟机)

软件:java-1.8、elasticsearch-5.6.16-1.noarch

错误信息:

2019-11-21T00:29:51,557ERRORo.e.b.Bootstrap elk-1 node validation exception

1 bootstrap checks failed

1: memory locking requested for elasticsearch process but memory is not locked

解决方法一(关闭bootstrap.memory_lock:,会影响性能):

vim /etc/elasticsearch/elasticsearch.yml // 设置成false就正常运行了。

bootstrap.memory_lock: false

解决方法二(开启bootstrap.memory_lock:):

  1. 修改文件/etc/elasticsearch/elasticsearch.yml,上面那个报错就是开启后产生的,如果开启还要修改其它系统配置文件

bootstrap.memory_lock: true

  1. 修改文件/etc/security/limits.conf,最后添加以下内容。
bash 复制代码
vim /etc/security/limits.conf 
bash 复制代码
* soft nofile 65536

* hard nofile 65536

* soft nproc 32000

* hard nproc 32000

* hard memlock unlimited

* soft memlock unlimited
  1. 修改文件 /etc/systemd/system.conf ,分别修改以下内容。
bash 复制代码
DefaultLimitNOFILE=65536

DefaultLimitNPROC=32000

DefaultLimitMEMLOCK=infinity

改好后重启下系统。再启动elasticsearch就没报错了 。

bash 复制代码
vim /etc/sysctl.conf

保存文件并执行以下命令使修改生效:

bash 复制代码
   sysctl -p

es7.13.2启动报错:

bootstrap checks failed 1 of 2: max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144

bash 复制代码
vim /etc/sysctl.conf

vm.max_map_count=262144

 sysctl -p
相关推荐
亚川楼宇自控系统数据中心厂家1 小时前
实验室智能化管理系统|人环物智一体化管控平台
运维
zmsup3 小时前
Agent 上下文调优:结合 OpsArk 运维智能体,设计模型每一步真正需要的信息
运维·agent·上下文压缩·运维智能体·上下文调优
吴声子夜歌5 小时前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng5 小时前
NRPE 添加命令(一)
linux·运维·服务器
pt10435 小时前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议
沫璃染墨6 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
HAHAXX87 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础1237 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
程序猿老A8 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
Ruiery9 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器