数据结构-怀化学院期末题(58)

今天发现了一个事情,学校平台可以交c++代码,那以后都用c++。但是不可以使用迭代器,否则会出现编译错误!!!

题目描述:

小学求算式问题。要求采用栈实现。

输入:

输入第一行为用例个数n。

接下来n个表达式。

输出:

对每一个用例的表达式,输出其结果。

输入样例:

3

2+5

4+2*3-10/5

3*7-2

输出样例:

7

8

19

代码:

cpp 复制代码
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<string.h>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<map>
using namespace std;
typedef pair<int,int> PII;
const int N = 1e5 + 10;
struct node{
	double num;  //操作数
	char op;  //操作符
	bool flag;  //true->操作数,false->操作符
};
string str;
stack<node> s;  //操作符栈
queue<node> q;  //后缀表达式序列
map<char,int> op;
void Change(){
	double num;
	node temp;
	for(int i = 0;i < str.length();){
		if(str[i] >= '0' && str[i] <= '9'){  //如果是数字
			temp.flag = true;  //标记是数字数
			temp.num = str[i++] - '0';
			while(i < str.length() && str[i]>='0' && str[i]<='9'){
				temp.num = temp.num * 10 + (str[i] - '0');
				i ++;
			}
			q.push(temp);
		}else{  //如果是操作符
			temp.flag = false;
			while(!s.empty() && op[str[i]] <= op[s.top().op]){
				q.push(s.top());
				s.pop();
			}
			temp.op = str[i];
			s.push(temp);
			i ++;
		}
	}
	while(!s.empty()){
		q.push(s.top());
		s.pop();        
	}
}
double Cal(){
	double temp1,temp2;
	node cur,temp;
	while(!q.empty()){
		cur = q.front();
		q.pop();
		if(cur.flag == true) s.push(cur);
		else{
			temp2 = s.top().num;
			s.pop();
			temp1 = s.top().num;
			s.pop();
			temp.flag = true;
			if(cur.op == '+') temp.num = temp1 + temp2;
			else if(cur.op == '-') temp.num = temp1 - temp2;
			else if(cur.op == '*') temp.num = temp1 * temp2;
			else temp.num = temp1 / temp2;
			s.push(temp);
		}
	}
	return s.top().num;
}
int main(){
	op['+'] = op['-'] = 1;
	op['/'] = op['*'] = 2;
	int rrrr;
	cin >> rrrr;
	getchar();
	int num = 0;
	while(getline(cin,str),str != "0"){
		while(!s.empty()) s.pop();//初始化栈
		Change();  //中缀表达式转后缀表达式
		printf("%.d\n",int(Cal()));  //计算后缀表达式
		num ++;
		if(num == rrrr) return 0;
	}
	return 0;
}
相关推荐
Run_Teenage1 小时前
手撕——贪吃蛇小游戏(下)
c语言·数据结构·链表
PXM的算法星球2 小时前
【leetcode】3524 求出数组的X值1
算法·leetcode·职场和发展
椰羊~王小美4 小时前
LeetCode -- Flora -- edit 2025-04-27
算法·leetcode·职场和发展
charade3125 小时前
【C语言】内存分配的理解
c语言·开发语言·c++
缘友一世5 小时前
从线性回归到逻辑回归
算法·逻辑回归·线性回归
前端_学习之路6 小时前
javaScript--数据结构和算法
javascript·数据结构·算法
weixin_428498496 小时前
使用HYPRE库并行装配IJ稀疏矩阵指南: 矩阵预分配和重复利用
算法·矩阵
雾削木8 小时前
mAh 与 Wh:电量单位的深度解析
开发语言·c++·单片机·嵌入式硬件·算法·电脑
__lost8 小时前
小球在摆线上下落的物理过程MATLAB代码
开发语言·算法·matlab
8RTHT9 小时前
数据结构(七)---链式栈
数据结构