tcpdump出现permission denied

  • 在使用tcpdump -i eth0 src host 192.168.0.184 and ip and port 22 -nn -w ping.pacp命令抓包并把抓到的数据保存到ping.pacp时,出现了权限错误的报错。
  • 但实际上我这里用的是root用户执行的命令。
  • 查阅man手册发现:

  • 在tcpdump中,-Z选项用于在启动数据包捕获后降低程序的权限,从而增强系统的安全性。默认开启

  • 如果tcpdump以root用户身份运行,它将在打开用于捕获数据包的设备或输入保存文件后,更改其运行时的用户ID(UID)和组ID(GID)。它会切换到指定的user的UID和该user的主组GID。

  • 这样做的目的是减少tcpdump拥有的权限,因为以root身份运行的进程如果被恶意利用,可能会对系统造成严重的安全风险。

  • 那么如果使用root用户遇到这个问题,可以使用-Z root指定root身份执行tcpdump,从而关掉这个默认选项

相关推荐
比兔代理5 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog6 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog6 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
Ivanqhz7 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
骇客野人8 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender9 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
网安小学生(兼顾数据库版)9 小时前
固件+软件供应链:ONEKEY+Mend如何实现全链路安全覆盖
网络·安全·web安全
Wang's Blog9 小时前
Java 项目实战: 外卖平台-删除分类的关联校验与自定义业务异常
java·服务器·项目开发
zly35009 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
学习中的码虫10 小时前
网络编程5
服务器·网络