尝试添加服务器中正在运行的docker容器时报错:当前用户没有运行“docker”的权限

尝试添加服务器中正在运行的docker容器时报错:当前用户没有运行"docker"的权限

环境

1,通过vscode ssh到服务器的

2,服务器端有一个contianer,但是无法通过vscode的Dev contianer组件将服务器中正在运行的contianer添加过来

3,值得注意的一点是,我没有把当前用户添加到docker用户组中,这也是报错的原因

报错内容

解决办法

当前用户添加到docker用户组中

bash 复制代码
sudo groupadd docker
sudo gpasswd -a {你的用户名} docker
sudo service docker restart

然后一定要exit你的当前用户,不行就重启一下服务器。

原因分析

我的vscode通过ssh连到服务器,(在你没有切换用户前)它的一切操作在服务器那端被识别为你访问服务使用的User的用户的操作,如果你没有把这个用户添加到docker的用户组中,那自然vscode是没有权限访问的

相关推荐
骇客野人2 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
比兔代理3 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog4 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog4 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
九皇叔叔5 小时前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技5 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz5 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese5 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky6 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南7 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸