mysql从库重新搭建的流程

背景

生产环境上的主从集群,因为一些异常原因,导致主从同步失败。现记录下通过重做mysql从库的方式来解决,重做过程不影响主库。

步骤

1、在主库上的操作步骤

备份主库所有数据,并将dump.sql文件拷贝到从库/tmp目录

复制代码
 ```sql
 mysqldump -uroot -p --set-gtid-purged=OFF --single-transaction --master-data=1 --all-databases > dump.sql
 ```

 #### **备注:**
  • 如果出现报错`Can't connect to local MySQL server through socket`可以执行netstat -ln | grep mysql命令查看mysql socket的地址需要添加参数 --socket=/u/mysql/tmp/mysql.sock 再次执行即可

    sql 复制代码
    mysqldump -uroot -p --set-gtid-purged=OFF --single-transaction --master-data=1 --all-databases --socket=/u/mysql/tmp/mysql.sock > dump.sql
  • --single-transaction参数是mysqldump在全量数据导入是对锁的一些处理,都应该加上该参数

  • --master-data=1参数是在备份文件中有 CHANGE MATER TO xxxxx命令,对备库有用,默认值为1,如果为2,就是把该条语句注释了。

2、在从库的操作

  • 通过mysql-client使用root用户登录上mysql

  • 停止从库:

    sql 复制代码
    stop slave;
  • 重置从库:

    sql 复制代码
    reset slave all;
  • 导入主库的数据:

    sql 复制代码
    source /tmp/dump.sql;
  • 查看dump.sql文件里面主库同步的位点:

  • 然后在从库执行

    sql 复制代码
    CHANGE MASTER TO MASTER_HOST='XXXXX',MASTER_USER='REPL',MASTER_PASSWORD='XXXX',MASTER_LOG_FILE='mysql-bin.002029',MASTER_LOG_POS=486015475;
  1. 假如需要旧用户密码忘记了,可以新建用户和密码作为主从复制的用户

    sql 复制代码
    #登录 MySQL 主库,创建用于复制的账号并授权:
       ```
       mysql -u root -p
       ```
       ```
       CREATE USER 'replication'@'从库IP地址' IDENTIFIED BY 'password';
       GRANT REPLICATION SLAVE ON *.* TO 'replication'@'从库IP地址';
       FLUSH PRIVILEGES;
  2. 在从库上再次执行

    sql 复制代码
     #在从库上登录 MySQL,并执行以下命令:
       ```
       mysql -u root -p
       ```
       ```
       CHANGE MASTER TO MASTER_HOST='主库IP地址',
       MASTER_USER='replication',
       MASTER_PASSWORD='password',
       MASTER_LOG_FILE='主库的binlog文件名',
       MASTER_LOG_POS=主库的binlog位置;
  • 开启同步:

    sql 复制代码
    start slave;
  • 查看同步状态:

    sql 复制代码
    show slave status\G;
  1. 如果发现`Authentication plugin 'caching_sha2_password' reported error: Authentication requires secure connection`报错

  2. 解决方法:

  • 在从库上执行一下命令即可,出现该报错的原因是因为mysql8.0默认要求连mysql需要安全连接

sql 复制代码
stop slave;
CHANGE MASTER TO GET_MASTER_PUBLIC_KEY=1;
start slave
相关推荐
刘胡子大叔6 小时前
MySQL 升到 8.4 前的兼容性自检清单
mysql
IT古董6 小时前
《FDE前沿部署工程师实战教程》33 - Enterprise AI Observability:从Agent Trace到全链路智能运维
数据库·人工智能
for_ever_love__6 小时前
MySQL 主从复制讲透:binlog 原理、搭建步骤与读写分离
java·数据库·mysql·binlog·读写分离·原理·主从复制
Nturmoils10 小时前
GROUP BY 先别想当然,查汇总前把规则跑清楚
数据库
最笨的羊羊11 小时前
Oceanbase数据库系列之:向量数据库核心知识
数据库·oceanbase
fish_xk11 小时前
mysql中的表的约束
数据库·mysql
谢亮_vipxieliang11 小时前
Go Channel 高级模式——从底层原理到扇出扇入实战
java·数据库·golang
ggaofeng12 小时前
自己编写邮件服务器和客户端
数据库
java1234_小锋12 小时前
【技术专题】Mysql8 数据库 - Mysql8 添加,更新,删除数据
数据库·mysql
PaperData12 小时前
2015-2024年各省绿色贸易数据
数据库