Flink启动Yarn Session报错:Couldn‘t deploy Yarn session cluster

Flink版本:1.1.3

启动Yarn Session的语句:bin/yarn-session.sh -nm test -d

报错截图如下:

仅通过ERROR信息只能知道是yarn session集群未能正常启动,因此继续向下查找:

找到报错信息的Caused by部分:

报错信息为:Permission denied: user=root, access=WRITE,inode="/user":why:supergroup:drwxr-xr-x

可以看到是权限问题,意为在root用户下没有相应权限,引起将用户切换为why即可;

相关推荐
Devlive 开源社区8 小时前
AuthX 正式更名 GrantForge:我们重新做了一遍权限管理系统
大数据·人工智能·架构
楚楚2519 小时前
2026企业AI办公工具选型指南:落地评估与效果衡量体系
大数据·人工智能
卷毛迷你猪10 小时前
快速实验篇(B16)用户级预测可行性审计(否定性意见)
大数据·hadoop·数据挖掘·聚类
盟接之桥10 小时前
当大模型遇见线束制造:不是通用AI,而是行业AI
大数据·网络·人工智能·安全·制造
归秋14211 小时前
2026 企业 AI 办公工具选型指南:从评估框架到产品适配
大数据·运维·人工智能
枯木◊靠推文躺平版12 小时前
2026 企业级 AI 办公平台选型指南:如何评估可落地的办公 AI 能力
大数据·人工智能
weidian66612 小时前
小红书广告投放形式和小红书广告投放核心流程
大数据
龙亘川13 小时前
数智驱动民政升级 精准守护民生保障
大数据·数据库·人工智能
小蒋观天下14 小时前
端侧大模型在安防摄像头部署实操(上)|行业痛点、架构选型、落地思路解析
大数据·人工智能·安全·计算机视觉·ai大模型
Elastic 中国社区官方博客14 小时前
使用 Lucene 搜索你的 Bean — 索引
java·大数据·数据库·elasticsearch·搜索引擎·全文检索·lucene