| 参数名 | 含义 | 默认值 | 解释 |
|---|---|---|---|
| max.request.size | 生产端:最大请求字节大小 | 1MB | 如果生产请求消息体大小大于该值,客户端生产时会报错 |
| max.poll.records | 消费端:一次poll()请求最大拉取消息条数 | 500条 | 如果单条消息处理时间长,需要减少该参数值,反之增加 |
| fetch.min.bytes | 消费端:一次poll()请求最小返回字节大小 | 1 | 增加该值可以提高吞吐量,同时也会产生一定延迟 |
| fetch.max.bytes | 消费端:一次poll()请求最大返回字节大小 | 50MB | 注意:若在第一个非空分区中拉取的第一条消息大于该值,消息仍会被返回 |
| fetch.max.wait.ms | 消费端:返回消息大小不满足fetch.min.bytes时最长等待时间 | 500ms | 与fetch.min.bytes参数共同作用 |
| batch.size | linear.ms 与batch.size共同控制消息异步发送频率;当batch大小达到batch.size或满足linger.ms时间间隔时,消息 | 16KB | 如果期望提高吞吐量,可以增加至 100000--200000;如果期望低生产时延,则建议使用默认值; |
| linger.ms | linear.ms 与batch.size共同控制消息异步发送频率;当batch大小达到batch.size或满足linger.ms时间间隔时,消息 | 0 | 如果希望提高吞吐量,可以增加至 10--100;如果期望低生产时延,则建议使用默认值 |
| message.max.bytes | 服务端配置,控制服务端接受可的最大生产批次消息大小 | 1MB | 如果生产请求消息体大小大于该值,服务端会返回错误响应;如果开启了消息压缩,则校验压缩后消息体大小 |
| max.partition.fetch.bytes | 消费端:一次poll()请求每个分区最大返回字节大小 | 1MB |
Kafka常见参数
沉默终止2024-01-31 16:19
相关推荐
灯澜忆梦13 小时前
【RabbitMQ #10】 | MQ可靠性醉颜凉15 小时前
Kafka 与 RabbitMQ/RocketMQ 选型对比:场景匹配、性能基准与迁移成本逐流人17 小时前
Ceph分布式存储集群配置与池管理:从配置优先级到PG、复本池与纠删码池天天喝旺仔20 小时前
gRPC 底层原理:HTTP/2 多路复用、Protobuf 序列化与四种流模式灯澜忆梦1 天前
【RabbitMQ #5】 | 三大交换机 Fanout ,Direct ,Topic筑梦之路1 天前
K8S yaml文件部署kafka集群(Kraft模式)——筑梦之路.冰块.1 天前
Ceph 分布式存储实战(二):存储池管理与 cephx 认证授权我们从未走散1 天前
从内存字典到租约内核:分布式上游账号池如何做到不超卖筑梦之路1 天前
Kafka KRaft 模式 Kubernetes 部署手册(StatefulSet + apache/kafka 官方镜像)——筑梦之路