微服务 docker-compose部署etcd

GO微服务 docker-compose部署etcd

最近在学习golang的微服务, 使用的是go-zero。微服务就会涉及到grpc和etcd,本地开发调试完成后,就计划上线,部署到腾讯云。踩坑就开始了。

踩坑开始,先说结论。

原因是腾讯云服务里的文件夹权限不够,导致docker启动成功,但连接失败。大无语,错怪了腾讯云的防火墙。

gitee新开一个etcd仓库

仓库文件整体结构如下所示。里面的.drone.yml文件可能比较陌生, 他的作用是drone的CI/CD的配置文件,.env是给doker使用的环境变量 docker-compose.yml是docker部署文件。

  • .drone.yml

  • .env

  • docker-compose.yml

.drone.yml 再次推荐CICD工具: drone

volumes的作用是调用服务器上的docker,when的tag, 是打tag进行部署。

yaml 复制代码
pipeline:
  build-dev:
    image: docker
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
    commands:
      - docker-compose down
      - docker-compose build
      - docker-compose up -d
    when:
      event: tag
      branch: '*'
      ref: refs/tags/dev.*
    privileged: true

.env

ini 复制代码
ETCD_DIR=/home/ubuntu/etcd
ETCD_VERSION=latest
ETCD_PORT=2379

docker-compose.yml

最终成功版 , volumes数据卷,用于在 Docker 容器和主机之间持久化存储数据,权限不够的话, 就会访问失败。

yaml 复制代码
version: '3'

services:
  etcd1:
    container_name: etcd1
    image: bitnami/etcd:$ETCD_VERSION
    deploy:
      replicas: 1
      restart_policy:
        condition: on-failure
    environment:
      ETCD_ROOT_PASSWORD: qwerdf
    privileged: true
    volumes: 
      - $ETCD_DIR/data:/bitnami/etcd/data  <-罪魁祸首就是你,ETCD_DIR文件夹没给权限。
    ports:
      - $ETCD_PORT:2379
      - 2380:2380

部署成功后,检查docker运行状态

你看多好,docker一切正常。

开始连接,但是连接失败。

连接失败时报错,context deadline exceeded,这个报错就坑我,网上都是说网络问题。

查询一下,都说是网络问题,我就按照网络的思路,各种折腾腾讯云的端口,最后发现不是端口的问题。 是docker就没部署成功。

相关推荐
码事漫谈27 分钟前
五道题,测测你有没有真的入门 AI
后端
蜗牛互联网1 小时前
Python + JSON Schema 实现工单结构化输出与本地复核
java·人工智能·后端
大侠归来2 小时前
Spring Boot 2.1 → 3.5 迁移推演:从实战出发的完整路线图
java·spring boot·后端
海马3 小时前
Spring Boot 开发知识整理
java·spring boot·后端
谢亮_vipxieliang3 小时前
Spring Boot 3.x 从零开始——环境搭建与第一个 REST 项目
java·spring boot·后端
念何架构之路3 小时前
go-grpc核心抽象接口
开发语言·后端·golang
FYKJ_20103 小时前
django个性化新闻推荐35173-计算机课程设计、毕业设计
java·spring boot·后端·python·架构·django·课程设计
小小龙学IT3 小时前
etcd 深度解析:Go 分布式一致性 KV 存储与 Raft 共识实战
分布式·golang·etcd
夜之眷属3 小时前
服务启动即崩:InetAddress.getLocalHost() 抛 UnknownHostException 排查记
java·运维·后端·docker