服务器管理员添加无密码登陆的ubuntu账户方法(RSA密钥

还记得曾经被黑客跳脸的痛苦经历,以及目睹着总有用户不改密码的无奈现实。痛定思痛,干脆都用密钥登陆得了,不会就学,不学就走

步骤如下

  1. 新用户想用服务器,就要来他的公钥,要求使用工具ssh-key-gen 用RSA算法生成
  2. 在服务器上执行以下命令:useradd -m -d /home/${username} -s /bin/bash ${username}
    • -m 自动创建主目录
    • -d 指定主目录
    • -s 指定登陆shell
    • username是一个bash变量,其值设置为新用户想用的值
  3. 使用命令su ${username} 进入该人账户
  4. 创建 ~/.ssh 目录以保存ssh登陆相关配置
  5. 创建空文件~/.ssh/authorized_keys,并将公钥的内容复制粘贴进去
  6. 将.ssh文件夹权限设置为700,将.ssh/authorized_keys的权限设置为600
  7. 使用命令grep PubkeyAuthentication /etc/ssh/sshd_config 来检查服务器是否开启了密钥登陆。
    • 该命令的结果如果是PubkeyAuthentication yes则开启了
  8. 管理员清除所有本地记录,要求新用户检查是否可以登陆
相关推荐
大侠归来1 小时前
Ubuntu 搭建 APUE 环境:从源码编译到第一个示例跑通
linux·运维·ubuntu
北京中科新远科技3 小时前
AI网卡五层检查法:协议、PCIe、NUMA、端口与验收
服务器·网络·人工智能
shdkfbbv3 小时前
【无标题】
linux·运维·服务器
wp123_13 小时前
TLVR 电感在 AI 服务器电源中的应用与市场前景分析
服务器·人工智能·科技·ai·硬件工程
ycvv4 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
_upupup4 小时前
包管理器和vim
linux·服务器
一颗小树x4 小时前
NVIDIA 驱动故障排查实录:内核升级导致 nvidia-smi 失效
linux·服务器·nvidia驱动·启动失败·内核升级
_smart_boy__4 小时前
I.MX6U开发板Uboot无法ping Ubuntu问题解决方案(二)
linux·运维·ubuntu
DianSan_ERP5 小时前
多平台订单自动下载与回传的技术实现:从消息推送到状态闭环引言
java·linux·服务器·前端·网络·架构·自动化
流星。。方5 小时前
网站做好了怎么上线?从域名解析到访问验证的完整实操
服务器