Oracle service failover后自动切回原来的node

After database service resources in CRS failed over to another node in a RAC Cluster, they were terminated and automatically fail back to the original node incorrectly.

CAUSE

The "fail back" was actually a relocation of the service resource, initiated by user process(UiServer):


crsd_148.trc:2017-12-19 12:24:32.701587 :UiServer:1239340800: {1:54916:896} Container [ Name: UI_RELOCATE

crsd_148.trc:2017-12-19 12:24:32.701630 :UiServer:1239340800: {1:54916:896} Sending to PE. ctx= 0x7f830003a9f0, ClientPID=96087 ===========>

crsd_148.trc:2017-12-19 12:24:32.707319 :UiServer:1239340800: {1:54916:896} Response: c4|5!ORDERk7|MESSAGEt79|CRS-2673: Attempting to stop 'ora.orcl.orclsrv.svc' on 'node1'k7|MSGTY

PEt1|3k5|OBJIDt33|ora.orcl.orclsrv.svc 1 1k4|WAITt1|0

crsd_148.trc:2017-12-19 12:24:32.777894 :UiServer:1239340800: {1:54916:896} Response: c4|5!ORDERk7|MESSAGEt78|CRS-2677: Stop of 'ora.orcl.orclsrv.svc' on 'node1' succeededk7|MSGTYP

Et1|3k5|OBJIDt33|ora.orcl.orclsrv.svc 1 1k4|WAITt1|0

crsd_148.trc:2017-12-19 12:24:32.780142 : AGFW:1251948288: {1:54916:896} Agfw Proxy Server received the message: RESOURCE_STARTora.orcl.orclsrv.svc 1 1 ID 4098:8698047

crsd_148.trc:2017-12-19 12:24:32.780238 : AGFW:1251948288: {1:54916:896} Creating the resource: ora.orcl.orclsrv.svc 1 1

crsd_148.trc:2017-12-19 12:24:32.780339 : AGFW:1251948288: {1:54916:896} Initializing the resource ora.orcl.orclsrv.svc 1 1 for type ora.service.type

crsd_148.trc:2017-12-19 12:24:32.780380 : AGFW:1251948288: {1:54916:896} SR: acl = owner:oracle:rwx,pgrp:dba:r--,other::r--,group:dba:r-x,user:oracle:r-x

crsd_148.trc:2017-12-19 12:24:32.780665 : AGFW:1251948288: {1:54916:896} Agfw Proxy Server sending message: RESOURCE_ADDora.orcl.orclsrv.svc 1 1 ID 4356:2828 to the agent /u01/app/12.1.0.2/grid/bin/oraagent_oracle

The relocate was initiated by a clientPID 96087, using a "JAVA" program:

2017-12-19 12:24:32.701587 :UiServer:1239340800: {1:54916:896} Container [ Name: UI_RELOCATE

API_HDR_VER:

TextMessage3

CLIENT:

TextMessage\[\]

CLIENT_NAME:
TextMessagejava ==============>

CLIENT_PID:
TextMessage96087 ================>

CLIENT_PRIMARY_GROUP:

TextMessagedba

Further analysis showed that this was caused due to the presence of a custom FAN (Fast Application Notification) script defined inside the $GRID_HOME/racg/usrco directory. The following example of the custom script shows that it forcibly relocates a service back to the preferred node after it has failed over to an available node:

Custom script:

if service is not running, then start it

echo " service stopped, starting" >> "$LOGFILE"

ORACLE_HOME/bin/srvctl start service -d "DATABASE" -s "service" \>\> "LOGFILE"

else

Service is running, but is it running on preferred instance?

RUNNING=( 'echo "$SRVSTATUS" | sed -rne "s/.* (a-zA-Z0-9+)/\1/p" | tr "," "\n"' )

echo "{RUNNING\[@\]} = {PREFERRED@}"

if ! in_array "INSTANCE" "{RUNNING@}" ; then

echo " not running on preferred INSTANCE" \>\> "LOGFILE"

Find the first non-preferred running instance

CURRENT=""

for inst in "${RUNNING@}"; do

if ! in_array "inst" "{PREFERRED@}" ; then

CURRENT="$inst"

break

fi

done

Relocate

if \[ -n "$CURRENT" ]; then

echo " relocate CURRENT -\> INSTANCE" >> "LOGFILE" **ORACLE_HOME/bin/srvctl relocate service -d "DATABASE" -s "service" -i "CURRENT" -t "INSTANCE" >> "$LOGFILE" <<<<<<<<<<<<<<<<<<<<<** <<<

fi

else

Service is already running on preferred instance, no need to do anything

echo " running on preferred INSTANCE" \>\> "LOGFILE"

fi

fi

fi

fi

done

SOLUTION

  1. If the custom script is a requirement in the environment, ignore the relocation.

  2. If the custom script is not a requirement or not wanted, verify and remove any user defined scripts in the '$GRID_HOME/racg/usrco' directory that were created for the services fail back.

相关推荐
꯭自꯭闭꯭11 分钟前
达梦SQL优化相关
linux·运维·数据库·sql
对空六课39 分钟前
支持注意力分析的热力图工具有哪些?
前端·数据库·数据分析
南京码讯光电技术有限公司1 小时前
How to Design an Antenna System for an Industrial WiFi Module
数据库·人工智能
lusklusklusk2 小时前
Oracle数据库基础之2_体系结构
数据库·oracle
可乐ea2 小时前
从第一性原理构建 AI Agent:提示词、工具、技能与记忆全解剖
数据库·人工智能·工具调用·ai智能体·提示词工程·agent开发·智能体记忆
东方护航数据恢复(深圳)3 小时前
医疗案例:HIS/PACS 数据库页损坏修复,医院不停诊完成恢复【东方护航数据恢复深圳店】
数据库·数据恢复·医疗·二次开盘
lusklusklusk4 小时前
Oracle数据库基础之11_Duplicate和Dataguard和RAC
数据库·oracle
PHP实战开发录5 小时前
MySQL字段加索引为什么没变快
数据库·mysql·php·开发
红红谈说6 小时前
标签化推送与已读统计怎么做?一次通知链路的工程复盘
数据库·消息推送·数字乡村·集合运算·已读回执·标签体系·写入放大
Shadow(⊙o⊙)6 小时前
MySQL索引
数据库·mysql