【云原生运维问题记录】kubesphere登录不跳转问题

文章目录

结论先行 :kubesphere-system名称空间下reids宕机重启,会判断是否通过registry-proxy重新拉取镜像,该镜像原本是通过阿里云上拉取,代理上没有出现超时情况,导致失败。
解决方案 :删除registry-proxy或修改registry-proxy配置

现象

kubesphere控制台点击登录不跳转

问题排查

  1. 查看kubesphere-system空间情况
yaml 复制代码
kubectl get all -n kubesphere-system

发现redis没起来

  1. kubesphere控制台模块ks-console,查看日志确认问题是什么引起
yaml 复制代码
kubectl logs <ks-console> -n kubesphere-system

结论:reids没起来导致的kubesphere登录不上

  1. 定位reids启动失败原因

由于reids pod没有创建 只能通过事件定位,查看kubesphere-system空间下事件

yaml 复制代码
kubectl get events  -n kubesphere-system
yaml 复制代码
m27s       Warning   FailedCreate        replicaset/redis-57f4b4584b                       Error creating: Internal error occurred: failed calling webhook "registry-proxy.registry-proxy.svc": failed to call webhook: Post "https://registry-proxy.registry-proxy.svc:443/mutate?timeout=3s": dial tcp 10.20.3.39:443: connect: connection refused

失败原因是通过registry-proxy调用错误,卸载registry-proxy,删除registry-proxy命名空间下所有资源,看是否恢复

  1. 卸载registry-proxy

卸载参考:https://ketches.cn/registry-proxy/

  1. 修改reids副本,重启
yaml 复制代码
kubectl scale deployment redis --replicas=0 -n kubesphere-system
kubectl scale deployment redis --replicas=1 -n kubesphere-system
  1. 查看部署情况
yaml 复制代码
kubectl get deployments -n kubesphere-system
  1. 再次登录成功
  1. registry-proxy用途还是比较大的,采用修改配置解决上述问题

配置参考:https://ketches.cn/registry-proxy/

修改默认配置:excludeNamespaces中添加kubesphere-system

yaml 复制代码
apiVersion: v1
kind: ConfigMap
metadata:
  name: registry-proxy-config
  namespace: registry-proxy
data:
  config.yaml: |
    enabled: true
    proxies:
      docker.io: docker.ketches.cn
      registry.k8s.io: k8s.ketches.cn
      quay.io: quay.ketches.cn
      ghcr.io: ghcr.ketches.cn
      gcr.io: gcr.ketches.cn
      k8s.gcr.io: k8s-gcr.ketches.cn
      docker.cloudsmith.io: cloudsmith.ketches.cn
    excludeNamespaces:
    - kube-system
    - kube-public
    - kube-node-lease
    - registry-proxy
    - kubesphere-system
    includeNamespaces:
    - *
相关推荐
Είναι η κοπέλα6 分钟前
WSL2 部署 AI 开发环境:内核级 Linux + GPU 直通
linux·运维·人工智能
其实防守也摸鱼9 分钟前
网安自测题:掌握核心知识点的实用练习
linux·运维·服务器·前端·数据库·sql·xss
2401_8685347817 分钟前
简要说明PON下行和上传数据方式
运维·服务器·网络
weixin_4038101319 分钟前
iOS 自动化脚本怎么输入文字:代理、输入法与快捷指令三级方案
运维·ios·自动化
ai小陈9 小时前
GPU服务器租用存储验收:检查点写入与磁盘吞吐实战
运维·服务器·人工智能·ai·ssh·gpu算力
有毒的教程11 小时前
VMware仅主机模式:物理机 ↔ 虚拟机 文件共享
运维
山岚的运维笔记13 小时前
ComfyUI NVIDIA安装教程:官方便携版下载+run_nvidia_gpu.bat启动,8G显存Windows实操
运维·服务器·windows·笔记·prompt·aigc·comfyui
海宇大数据14 小时前
零信任架构实战:基于海宇活体识别V步骤1构建自动化远程公证会话初始化网关
运维·人工智能·架构·自动化
lisanmengmeng14 小时前
Nagios邮件报警的配置
linux·运维·服务器
Ruiery15 小时前
Linux 6.6内核 CPU 深度解析(六):cpufreq
linux·运维·服务器