[linux] kolla-ansible 部署的openstack 修改mariadb默认端口号

kolla-ansible 部署前修改global.yml

复制代码
#freezer_database_backend: "mariadb"
database_port: 9306
mariadb_port: 9306

如果已经部署成功,直接修改配置文件里的端口号重启是没有用的,怀疑内部做了缓存,查看openstack 使用的memcached,也没有什么结果,nova的所有服务与数据库交互的都报失败,打印日志发现,修改了配置,连接mysql端口仍然使用的3306,刚开始怀疑端口是不是没有从配置传下去,后来感觉,openstack不会犯这么sb的错误。本以为这个问题,几周了,也没收获了,算了,直到想想,还是再使劲定位下,打开了debug,所有与数据库交互的openstack都是直接调用的封装好的 oslo_db,在nova源码里搜索oslo

发现连接数据库用的缓存池,数据库的连接url原来是保存在一张表里。。。

还以为是个本地的sqlit数据库,没想到在nova_api数据库中果然存在这张cell_mappings映射信息表,直接修改了数据后,重启服务,db连接恢复正常。

openstack过于庞大,花了很多猜想,搜资料,本来用自己的经验去寻找答案,从来没想到过链接db时的url信息,保存在数据库里读取,做了缓存,就不从配置里读了。

复制代码
# 备份
cd /etc/kolla
sed -i "s/3306/9306/g" `grep 3306 -rl .`

navicat登录数据库,进入nova_api,修改表cell_mappings 字段database_connection内的端口号

systemctl restart docker
重启所有的服务
相关推荐
M78佐菲5 小时前
ARM学习笔记(1)
linux·arm开发·笔记·嵌入式硬件·学习
益达丫6 小时前
Socket编程揭秘:端口、IP与进程通信的底层逻辑
linux·笔记
chicheese9 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky9 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
vortex510 小时前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
JudithHuang11 小时前
创建第一台实例:Horizon ↔ CLI
openstack
JudithHuang11 小时前
Apple Silicon 上 Cirros 控制台VNC打不了字
openstack
INGNIGHT11 小时前
270 · 电话号码的字母组合II(Trie)
linux·算法
zly350011 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
GeW13 小时前
从内核到数据:Linux与工业数据库如何支撑高端制造
linux