Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
cpp
#include <iostream>
#include <queue>
using namespace std;
//广度优先队列 所有邻居都访问
//队列 集合是否被访问过的状态
struct info{//位置 时间
int pos;
int time;
};
int main() {
int n,k;
scanf("%d%d",&n,&k);
queue<info> posQueue;
bool isvisit[100001];
for(int i=0;i<100001;i++){
isvisit[i]= false;
}
info first;
first.pos=n;
first.time=0;
posQueue.push(first);
while(posQueue.empty()==false){
info cur=posQueue.front();
posQueue.pop();
if(cur.pos==k){
printf("%d\n",cur.time);
break;
}
isvisit[cur.pos]= true;//不是则改为已访问过
//把邻居加入到队列中
info neighbour;
if(cur.pos-1>=0 && cur.pos-1<=100000 && isvisit[cur.pos-1]==false){
neighbour.pos=cur.pos-1;
neighbour.time=cur.time+1;
posQueue.push(neighbour);
}
if(cur.pos+1>=0 && cur.pos+1<=100000 && isvisit[cur.pos+1]==false){
neighbour.pos=cur.pos+1;
neighbour.time=cur.time+1;
posQueue.push(neighbour);
}
if(cur.pos*2>=0 && cur.pos*2<=100000 && isvisit[cur.pos*2]==false){
neighbour.pos=cur.pos*2;
neighbour.time=cur.time+1;
posQueue.push(neighbour);
}
}
return 0;
}