每日一题 Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

复制代码
5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

cpp 复制代码
#include <iostream>
#include <queue>

using namespace std;
//广度优先队列 所有邻居都访问
//队列 集合是否被访问过的状态
struct info{//位置 时间
    int pos;
    int time;
};
int main() {
    int n,k;
    scanf("%d%d",&n,&k);
    queue<info> posQueue;
    bool isvisit[100001];
    for(int i=0;i<100001;i++){
        isvisit[i]= false;
    }
    info first;
    first.pos=n;
    first.time=0;
    posQueue.push(first);
    while(posQueue.empty()==false){
        info cur=posQueue.front();
        posQueue.pop();
        if(cur.pos==k){
            printf("%d\n",cur.time);
            break;
        }
        isvisit[cur.pos]= true;//不是则改为已访问过
        //把邻居加入到队列中
        info neighbour;
        if(cur.pos-1>=0 && cur.pos-1<=100000 && isvisit[cur.pos-1]==false){
            neighbour.pos=cur.pos-1;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
        if(cur.pos+1>=0 && cur.pos+1<=100000 && isvisit[cur.pos+1]==false){
            neighbour.pos=cur.pos+1;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
        if(cur.pos*2>=0 && cur.pos*2<=100000 && isvisit[cur.pos*2]==false){
            neighbour.pos=cur.pos*2;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
    }
    return 0;
}
相关推荐
ALISHENGYA14 分钟前
全国青少年信息学奥林匹克竞赛(信奥赛)备考实战之分支结构(switch语句)
数据结构·算法
chengooooooo15 分钟前
代码随想录训练营第二十七天| 贪心理论基础 455.分发饼干 376. 摆动序列 53. 最大子序和
算法·leetcode·职场和发展
jackiendsc22 分钟前
Java的垃圾回收机制介绍、工作原理、算法及分析调优
java·开发语言·算法
游是水里的游1 小时前
【算法day20】回溯:子集与全排列问题
算法
yoyobravery2 小时前
c语言大一期末复习
c语言·开发语言·算法
Jiude2 小时前
算法题题解记录——双变量问题的 “枚举右,维护左”
python·算法·面试
被AI抢饭碗的人2 小时前
算法题(13):异或变换
算法
nuyoah♂3 小时前
DAY36|动态规划Part04|LeetCode:1049. 最后一块石头的重量 II、494. 目标和、474.一和零
算法·leetcode·动态规划
上学的小垃圾3 小时前
MPLS基础以及静态LSP的配置
运维·网络·算法
图图爱上壮壮妈3 小时前
PHP中实现拓扑算法
开发语言·算法·php