每日一题 Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

复制代码
5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

cpp 复制代码
#include <iostream>
#include <queue>

using namespace std;
//广度优先队列 所有邻居都访问
//队列 集合是否被访问过的状态
struct info{//位置 时间
    int pos;
    int time;
};
int main() {
    int n,k;
    scanf("%d%d",&n,&k);
    queue<info> posQueue;
    bool isvisit[100001];
    for(int i=0;i<100001;i++){
        isvisit[i]= false;
    }
    info first;
    first.pos=n;
    first.time=0;
    posQueue.push(first);
    while(posQueue.empty()==false){
        info cur=posQueue.front();
        posQueue.pop();
        if(cur.pos==k){
            printf("%d\n",cur.time);
            break;
        }
        isvisit[cur.pos]= true;//不是则改为已访问过
        //把邻居加入到队列中
        info neighbour;
        if(cur.pos-1>=0 && cur.pos-1<=100000 && isvisit[cur.pos-1]==false){
            neighbour.pos=cur.pos-1;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
        if(cur.pos+1>=0 && cur.pos+1<=100000 && isvisit[cur.pos+1]==false){
            neighbour.pos=cur.pos+1;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
        if(cur.pos*2>=0 && cur.pos*2<=100000 && isvisit[cur.pos*2]==false){
            neighbour.pos=cur.pos*2;
            neighbour.time=cur.time+1;
            posQueue.push(neighbour);
        }
    }
    return 0;
}
相关推荐
ZZZ_O^O4 分钟前
【动态规划-卡特兰数——96.不同的二叉搜索树】
c++·学习·算法·leetcode·动态规划
一只小透明啊啊啊啊35 分钟前
Leetcode100子串
算法
木向35 分钟前
leetcode:114. 二叉树展开为链表
算法·leetcode·链表
sky_smile_Allen39 分钟前
[C#] 关于数组的详细解释以及使用注意点
开发语言·算法·c#
希望有朝一日能如愿以偿1 小时前
力扣题解(新增道路查询后的最短距离II)
算法
我感觉。1 小时前
【机器学习chp6】对数几率回归
算法·机器学习·逻辑回归·分类模型·对数几率回归
无限大.2 小时前
力扣题解3248 矩阵中的蛇(简单)
算法·leetcode·矩阵
灼华十一2 小时前
算法编程题-排序
数据结构·算法·golang·排序算法
谁在夜里看海.2 小时前
【从零开始的算法学习日记✨优选算法篇✨】第二章:流动之窗,探索算法的优雅之道
c++·学习·算法
SoraLuna2 小时前
「Mac玩转仓颉内测版25」基础篇5 - 布尔类型详解
开发语言·算法·macos·cangjie