Linux下创建用户并且赋root权限

背景:好几次都要求自己在服务器上创建用户,并且赋权限给这个用户的root权限,因为生产服务器上不让用root用户操作,之前没怎么记录,因为这个操作不多,但是又记不住这个操作,一到用上,就得去百度去,算了,核心的知识还是掌握在自己手里吧,记录一下。

第一步:创建用户
javascript 复制代码
adduser system_yunwei (你自己想要设置的用户名称)
第二步:给该用户设置密码
javascript 复制代码
passwd system_yunwei
第三步:验证是否能登录目前的服务器
第四步:给当前的用户赋root权限之前,先测试一下该用户现在的权限

可以尝试 fdisk -l 命令(该命令是root用户的才有的)

javascript 复制代码
fdisk -l 

此时这个命令执行完成后,应该报错没有权限

第五步:给给用户赋root权限

不要用下面的命令,会报错该文件只读

javascript 复制代码
vi /etc/sudoers

使用下面的命令

javascript 复制代码
visudo

在该文件中root用户这一行配置中添加如下即可

javascript 复制代码
root ALL=(ALL) ALL
system_yunwei ALL=(ALL) ALL
第六步:然后去验证该用户是否有root权限

执行下面的命令,如果不报错权限问题,则赋权限成功

javascript 复制代码
sudo fdisk -l 
相关推荐
未济1 天前
linux 配置环境变量
linux
傲世仙尊1 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫1 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
_艾伦 耶格尔.1 天前
进程间通信
linux
AI职业加油站1 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
Liuqy-051 天前
Linux IO编程——静态库、动态库
linux
此冬歌咏2 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
彧azz2 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog2 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发