【linux问题记录】

Linux普通用户登录后,命令行提示:-bash-4.2$ ,原因分析及解决

有时候在使用用户登陆Linux系统时会发现,命令行提示符成了:-bash-4.2$,不显示用户名,路径信息。

原因:

用户家目录里面与环境变量有关的文件被删除所导致的

也就是这俩文件:

.bash_profile

.bashrc

这两个文件被删除了,导致了这个错误

解决方法:

从/etc/skel把丢失的文件 复制回来就可以了

-bash-4.1$ cp /etc/skel/.bash* ~    

-bash-4.1$ logout

##复制回来后,登出用户,然后在登陆用户查看是否已经解决

root@rudy \~# su - rudy

转自https://www.cnblogs.com/little-bin/p/16908482.html

相关推荐
Java红桃峰峰日拱一卒1 小时前
在jdk8的centos上安装jdk17
linux·jdk17·jdk8
M78佐菲7 小时前
ARM学习笔记(1)
linux·arm开发·笔记·嵌入式硬件·学习
骇客野人7 小时前
Redis 完整安装部署方案(Linux,分【源码编译】+【Docker】两种,推荐生产用源码,测试快速用 Docker)
运维
益达丫8 小时前
Socket编程揭秘:端口、IP与进程通信的底层逻辑
linux·笔记
比兔代理8 小时前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog10 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog10 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
蓝速科技10 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz10 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese11 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维