Kubernetes集群上部署的elasticsearch服务运行报错:For complete error details

目录

一、问题描述:

二、问题分析:

1、排查当前容器里的elasticsearch服务数据目录权限:

2、检查elasticsearch用户的id值:

3、故障原因及故障处理方向结论:

三、问题处理:

四、总结:

一、问题描述:

在维护paas云平台时遇见一个elasticsearch服务运行异常,报错内容显示如下:

并且通过重启pod容器也无法恢复该elasticsearch服务。

二、问题分析:

通过日志内容及运维经验发现该问题是因为elasticsearch服务数据目录的权限不匹配导致,

1、排查当前容器里的elasticsearch服务数据目录权限:

通过上面的检查,得出两个信息:

(1).elasticsearch服务的数据目录的权限确实存在问题,其他的目录/文件的是elasticsearch用户,但是data目录的属主是root的,存在冲突;

(2).elasticsearch服务运行的用户是elasticsearch用户;

2、检查elasticsearch用户的id值:

需要登入到容器里通过id elasticsearch查看用户ID值

3、故障原因及故障处理方向结论:

根据上面分析的情况,需要将data目录的属主修改为 elasticsearch:root,就可以了。

三、问题处理:

根据上面分析的结论,需要将 elasticsearch容器里的data目录修改属主,但是考虑到后期可能还会触发该属主问题,所以建议需要在 elasticsearch容器里加入一个初始化容器来完成属主设置工作;

在spec模块之下添加如下的内容:

cpp 复制代码
      initContainers:
        - name: init-sysctl
          image: 'dockerhub.jxstjh.com/system_containers/busybox:latest'
          command:
            - /bin/sh
            - '-c'
            - >-
              chown -R 1000:1000 /usr/share/elasticsearch/data;sysctl -w
              vm.max_map_count=262144
          resources: {}
          volumeMounts:
            - name: video-elasticsearch-pvc
              mountPath: /usr/share/elasticsearch/data
          terminationMessagePath: /dev/termination-log
          terminationMessagePolicy: File
          imagePullPolicy: IfNotPresent
          securityContext:
            privileged: true

结果如下:其中有两处需要注意的,第一个 elasticsearch的数据目录,第二个是挂载目录信息

然后重启一下elasticsearch容器就可以了;后面通过验证,elasticsearch容器服务已经恢复了。

四、总结:

如上是elasticsearch容器服务维护过程中遇见的问题,并且是提供了处理方案,希望能帮助到大家!!

相关推荐
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
赵文宇(温玉)5 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
Elasticsearch5 天前
Elastic Observability 的跨项目搜索:通过一个查询搜索所有关联项目
elasticsearch
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
Elasticsearch5 天前
Elasticsearch 中的 agentic 工作流:暂停 AI agent 等待人工审批,72 小时后恢复
elasticsearch
忆~遂愿5 天前
本地片库怎么在外面打开?Plex + cpolar 搭一套可远程访问的私人影音库
docker·容器
Elastic 中国社区官方博客5 天前
jina-ocr-v1:在低成本 GPU 上实现更快速的文档解析
大数据·数据库·elasticsearch·搜索引擎·全文检索·jina
Thneonl5 天前
你的 Pod 为什么 Pending:调度器两阶段
后端·kubernetes
不吃香菜kkk、5 天前
CI/CD(GitOps)学习与部署手册
运维·云原生·容器·kubernetes·云计算·jenkins·argocd