1019. 庆功会(多重背包问题)

活动 - AcWing

为了庆贺班级在校运动会上取得全校第一名成绩,班主任决定开一场庆功会,为此拨款购买奖品犒劳运动员。

期望拨款金额能购买最大价值的奖品,可以补充他们的精力和体力。

输入格式

第一行二个数n,m,其中n代表希望购买的奖品的种数,m表示拨款金额。

接下来n行,每行3个数,v、w、s,分别表示第I种奖品的价格、价值(价格与价值是不同的概念)和能购买的最大数量(买0件到s件均可)。

输出格式

一行:一个数,表示此次购买能获得的最大的价值(注意!不是价格)。

数据范围

n≤500,m≤6000

v≤100,w≤1000,s≤10

输入样例:
5 1000
80 20 4
40 50 9
30 50 7
40 30 6
20 20 1
输出样例:
1040

解析: ​​​​​​P1776 宝物筛选(多重背包模板题)-CSDN博客

cpp 复制代码
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
#include<sstream>
#include<deque>
#include<unordered_map>
#include<unordered_set>
#include<bitset>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> PII;
typedef pair<double, double> PDD;
const int N = 8e2+10, M = 1e5 + 10;
const int INF = 1e8;
int n,m;
int vv[M], ww[M];
int f[M];

int main() {
	cin >> n >> m;
	int cnt = 0;
	for (int i = 1,v,w,s; i <= n; i++) {
		scanf("%d%d%d", &v, &w, &s);
		int t = 1;
		while (s >= t) {
			vv[++cnt] = t*v;
			ww[cnt] = t*w;
			s -= t;
			t *= 2;
		}
		if (s > 0) {
			vv[++cnt] = s * v;
			ww[cnt] = s * w;
		}
	}
	for (int i = 1; i <= cnt; i++) {
		for (int j = m; j >= vv[i]; j--)f[j] = max(f[j], f[j - vv[i]] + ww[i]);
	}
	cout << f[m] << endl;
	return 0;
}
相关推荐
myprogramc2 分钟前
十大排序算法
数据结构·算法·排序算法
记得早睡~5 分钟前
leetcode150-逆波兰表达式求值
javascript·算法·leetcode
qy发大财7 分钟前
跳跃游戏(力扣55)
算法·leetcode
BingLin-Liu10 分钟前
蓝桥杯备考:搜索算法之排列问题
算法·职场和发展·蓝桥杯
计算机小白一个13 分钟前
蓝桥杯 Java B 组之岛屿数量、二叉树路径和(区分DFS与回溯)
java·数据结构·算法·蓝桥杯
curemoon1 小时前
理解都远正态分布中指数项的精度矩阵(协方差逆矩阵)
人工智能·算法·矩阵
柃歌1 小时前
【UCB CS 61B SP24】Lecture 7 - Lists 4: Arrays and Lists学习笔记
java·数据结构·笔记·学习·算法
柃歌1 小时前
【UCB CS 61B SP24】Lecture 4 - Lists 2: SLLists学习笔记
java·数据结构·笔记·学习·算法
SKYDROID云卓小助手2 小时前
无人设备遥控器之如何分享数传篇
网络·人工智能·算法·计算机视觉·电脑
Lqingyyyy3 小时前
P2865 [USACO06NOV] Roadblocks G 与最短路的路径可重复的严格次短路
开发语言·c++·算法