1019. 庆功会(多重背包问题)

活动 - AcWing

为了庆贺班级在校运动会上取得全校第一名成绩,班主任决定开一场庆功会,为此拨款购买奖品犒劳运动员。

期望拨款金额能购买最大价值的奖品,可以补充他们的精力和体力。

输入格式

第一行二个数n,m,其中n代表希望购买的奖品的种数,m表示拨款金额。

接下来n行,每行3个数,v、w、s,分别表示第I种奖品的价格、价值(价格与价值是不同的概念)和能购买的最大数量(买0件到s件均可)。

输出格式

一行:一个数,表示此次购买能获得的最大的价值(注意!不是价格)。

数据范围

n≤500,m≤6000

v≤100,w≤1000,s≤10

输入样例:
5 1000
80 20 4
40 50 9
30 50 7
40 30 6
20 20 1
输出样例:
1040

解析: ​​​​​​P1776 宝物筛选(多重背包模板题)-CSDN博客

cpp 复制代码
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
#include<sstream>
#include<deque>
#include<unordered_map>
#include<unordered_set>
#include<bitset>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> PII;
typedef pair<double, double> PDD;
const int N = 8e2+10, M = 1e5 + 10;
const int INF = 1e8;
int n,m;
int vv[M], ww[M];
int f[M];

int main() {
	cin >> n >> m;
	int cnt = 0;
	for (int i = 1,v,w,s; i <= n; i++) {
		scanf("%d%d%d", &v, &w, &s);
		int t = 1;
		while (s >= t) {
			vv[++cnt] = t*v;
			ww[cnt] = t*w;
			s -= t;
			t *= 2;
		}
		if (s > 0) {
			vv[++cnt] = s * v;
			ww[cnt] = s * w;
		}
	}
	for (int i = 1; i <= cnt; i++) {
		for (int j = m; j >= vv[i]; j--)f[j] = max(f[j], f[j - vv[i]] + ww[i]);
	}
	cout << f[m] << endl;
	return 0;
}
相关推荐
luthane36 分钟前
python 实现average mean平均数算法
开发语言·python·算法
静心问道40 分钟前
WGAN算法
深度学习·算法·机器学习
杰九1 小时前
【算法题】46. 全排列-力扣(LeetCode)
算法·leetcode·深度优先·剪枝
manba_1 小时前
leetcode-560. 和为 K 的子数组
数据结构·算法·leetcode
liuyang-neu1 小时前
力扣 11.盛最多水的容器
算法·leetcode·职场和发展
忍界英雄1 小时前
LeetCode:2398. 预算内的最多机器人数目 双指针+单调队列,时间复杂度O(n)
算法·leetcode·机器人
Kenneth風车1 小时前
【机器学习(五)】分类和回归任务-AdaBoost算法-Sentosa_DSML社区版
人工智能·算法·低代码·机器学习·数据分析
C7211BA2 小时前
使用knn算法对iris数据集进行分类
算法·分类·数据挖掘
Tisfy2 小时前
LeetCode 2398.预算内的最多机器人数目:滑动窗口+单调队列——思路清晰的一篇题解
算法·leetcode·机器人·题解·滑动窗口
程序猿练习生2 小时前
C++速通LeetCode简单第18题-杨辉三角(全网唯一递归法)
c++·算法·leetcode