每日一题 第七十三期 洛谷 [蓝桥杯 2013 省 B] 带分数

[蓝桥杯 2013 省 B] 带分数

题目描述

100 100 100 可以表示为带分数的形式: 100 = 3 + 69258 714 100 = 3 + \frac{69258}{714} 100=3+71469258。

还可以表示为: 100 = 82 + 3546 197 100 = 82 + \frac{3546}{197} 100=82+1973546。

注意特征:带分数中,数字 1 1 1 ~ 9 9 9 分别出现且只出现一次(不包含 0 0 0)。

类似这样的带分数, 100 100 100 有 11 11 11 种表示法。

输入格式

从标准输入读入一个正整数 N ( N < 1 0 6 ) N(N<10^6) N(N<106)。

输出格式

程序输出数字 N N N 用数码 1 1 1 ~ 9 9 9 不重复不遗漏地组成带分数表示的全部种数。

注意:不要求输出每个表示,只统计有多少表示法!

样例 #1

样例输入 #1

100

样例输出 #1

11

样例 #2

样例输入 #2

105

样例输出 #2

6

提示

原题时限 3 秒, 64M。蓝桥杯 2013 年第四届省赛

AC代码:

cpp 复制代码
#include<map>
#include<set>
#include<stack>
#include<cmath>
#include<queue>
#include<string>
#include<bitset>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<numeric>
#include<iomanip>
#define endl '\n'
//#define x first
//#define y second
using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
//const int N=3e5+10;
const int MOD=1e9 + 7;
const int INF=0X3F3F3F3F;
const int dx[]={-1,1,0,0,-1,-1,+1,+1};
const int dy[]={0,0,-1,1,-1,+1,-1,+1};
const int M = 1e6 + 10;

int target;
int num[50];
bool use[50];
int cnt;
int cal(int l , int r)
{
	int res = 0;
	for(int i = l; i <= r; i ++)
	{
		res = res * 10 + num[i];
	}
	return res;
}
void dfs(int u)
{
	if(u == 9)
	{
		for(int i = 0; i < 7; i ++)
		{
			for(int j = i + 1; j < 8; j ++)
			{
				int a = cal(0, i);
				int b = cal(i + 1, j);
				int c = cal(j + 1, 8);
				if(a * c + b == c * target)cnt ++;
			}
		}
		return ;
	}
	for(int i = 1; i <= 9; i ++)
	{
		if(!use[i])
		{
			use[i] = true;
			num[u] = i;
			dfs(u + 1);
			use[i] = false;
		}
	}
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
	cin >> target;
	dfs(0);
	cout << cnt << endl;
}
相关推荐
C++忠实粉丝3 分钟前
计算机网络socket编程(4)_TCP socket API 详解
网络·数据结构·c++·网络协议·tcp/ip·计算机网络·算法
古月居GYH15 分钟前
在C++上实现反射用法
java·开发语言·c++
Betty’s Sweet17 分钟前
[C++]:IO流
c++·文件·fstream·sstream·iostream
敲上瘾31 分钟前
操作系统的理解
linux·运维·服务器·c++·大模型·操作系统·aigc
福大大架构师每日一题33 分钟前
文心一言 VS 讯飞星火 VS chatgpt (396)-- 算法导论25.2 1题
算法·文心一言
不会写代码的ys37 分钟前
【类与对象】--对象之舞,类之华章,共绘C++之美
c++
兵哥工控40 分钟前
MFC工控项目实例三十二模拟量校正值添加修改删除
c++·mfc
EterNity_TiMe_1 小时前
【论文复现】(CLIP)文本也能和图像配对
python·学习·算法·性能优化·数据分析·clip
长弓聊编程1 小时前
Linux系统使用valgrind分析C++程序内存资源使用情况
linux·c++
ifanatic1 小时前
[面试]-golang基础面试题总结
面试·职场和发展·golang