每日一题 第七十三期 洛谷 [蓝桥杯 2013 省 B] 带分数

[蓝桥杯 2013 省 B] 带分数

题目描述

100 100 100 可以表示为带分数的形式: 100 = 3 + 69258 714 100 = 3 + \frac{69258}{714} 100=3+71469258。

还可以表示为: 100 = 82 + 3546 197 100 = 82 + \frac{3546}{197} 100=82+1973546。

注意特征:带分数中,数字 1 1 1 ~ 9 9 9 分别出现且只出现一次(不包含 0 0 0)。

类似这样的带分数, 100 100 100 有 11 11 11 种表示法。

输入格式

从标准输入读入一个正整数 N ( N < 1 0 6 ) N(N<10^6) N(N<106)。

输出格式

程序输出数字 N N N 用数码 1 1 1 ~ 9 9 9 不重复不遗漏地组成带分数表示的全部种数。

注意:不要求输出每个表示,只统计有多少表示法!

样例 #1

样例输入 #1

复制代码
100

样例输出 #1

复制代码
11

样例 #2

样例输入 #2

复制代码
105

样例输出 #2

复制代码
6

提示

原题时限 3 秒, 64M。蓝桥杯 2013 年第四届省赛

AC代码:

cpp 复制代码
#include<map>
#include<set>
#include<stack>
#include<cmath>
#include<queue>
#include<string>
#include<bitset>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<numeric>
#include<iomanip>
#define endl '\n'
//#define x first
//#define y second
using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
//const int N=3e5+10;
const int MOD=1e9 + 7;
const int INF=0X3F3F3F3F;
const int dx[]={-1,1,0,0,-1,-1,+1,+1};
const int dy[]={0,0,-1,1,-1,+1,-1,+1};
const int M = 1e6 + 10;

int target;
int num[50];
bool use[50];
int cnt;
int cal(int l , int r)
{
	int res = 0;
	for(int i = l; i <= r; i ++)
	{
		res = res * 10 + num[i];
	}
	return res;
}
void dfs(int u)
{
	if(u == 9)
	{
		for(int i = 0; i < 7; i ++)
		{
			for(int j = i + 1; j < 8; j ++)
			{
				int a = cal(0, i);
				int b = cal(i + 1, j);
				int c = cal(j + 1, 8);
				if(a * c + b == c * target)cnt ++;
			}
		}
		return ;
	}
	for(int i = 1; i <= 9; i ++)
	{
		if(!use[i])
		{
			use[i] = true;
			num[u] = i;
			dfs(u + 1);
			use[i] = false;
		}
	}
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
	cin >> target;
	dfs(0);
	cout << cnt << endl;
}
相关推荐
算AI4 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
懒羊羊大王&5 小时前
模版进阶(沉淀中)
c++
owde6 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
GalaxyPokemon6 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi6 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh6 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
tadus_zeng7 小时前
Windows C++ 排查死锁
c++·windows
EverestVIP7 小时前
VS中动态库(外部库)导出与使用
开发语言·c++·windows
杉之7 小时前
选择排序笔记
java·算法·排序算法
Naive_77 小时前
蓝桥杯准备(前缀和差分)
java·职场和发展·蓝桥杯