Kibana启动报错:Kibana server is not ready yet

Kibana启动后,访问http://ip:5601后报错:Kibana server is not ready yet

原因1:Kibana和Elasticsearch的版本不兼容

解决方案:保持版本一致

原因2:Elasticsearch的服务地址和Kibana中配置的elasticsearch.hosts不同

解决方案:修改kibana.yml中elasticsearch.hosts配置

原因3:Elasticsearch中 禁止跨域访问

解决方案:在elasticsearch.yml中配置允许跨域

原因4:服务器中开启了防火墙

解决方案:关闭防火墙或者修改服务器的安全策略

原因5:Elasticsearch所在磁盘剩余空间不足90%

解决方案:清理磁盘空间,配置监控和报警

原因6:elasticsearch的启动命令中,鼠标选中了部分代码

解决方案:取消elasticsearch中命令行的选中状态,或者直接重启elasticsearch,再启动kibana

相关推荐
XiaoMaqqqq15 小时前
市面上正规的IP驱动产业新场景新工具哪家强
运维·python·网络协议·tcp/ip
huainingning16 小时前
RJ SW Console口忘记密码处理方法
linux·运维·服务器
布裘16 小时前
【银河麒麟】桌面系统循环登录,无法进入桌面?
linux·运维·服务器
慧都小项16 小时前
程序到了Linux才出错?用CLion把调试接到目标环境
linux·运维·服务器
Lsetea16 小时前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang17 小时前
docker的备份与迁移
运维·docker·容器
Ruiery18 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器
Android系统攻城狮18 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_max调用流程与实战(五十九)
linux·运维·服务器·gstreamer音视频·音视频进阶·gstreamer音视频进阶
忆挽篱笙歌19 小时前
makefil
linux·运维·服务器
程序员老赵20 小时前
Docker 部署 Dolibarr:轻松搭建开源 ERP/CRM 平台
运维·前端·后端