linux下 Mysql8.0 离线安装

环境:centos7.9

MysqlL8.0.36安装包

链接:https://pan.baidu.com/s/1bKwHr05z8Ye82dT9tntdUA

提取码:3a5z

参考Centos安装MYSQL8(离线可用)

文章目录

    • 1、解压安装
    • 2、配置启动
      • [2.1 修改配置文件](#2.1 修改配置文件)
      • [2.2 mysql 启动](#2.2 mysql 启动)
    • [3、mysql 测试](#3、mysql 测试)

1、解压安装

shell 复制代码
# 1.1 解压
> tar -xvf mysql-8.0.36-1.el7.x86_64.rpm-bundle.tar

# 1.2 安装
# -i:安装软件包。
# -v:在安装过程中显示详细的输出信息。
# -h:显示安装进度条。
# *.rpm:通配符 * 表示匹配当前目录下所有以 .rpm 结尾的文件,表示要安装所有以 .rpm 结尾的软件包。
# --nodeps:在安装软件包时不检查依赖关系。这意味着即使软件包的依赖关系未满足,也会强制安装。
# --force:强制安装软件包,即使已经安装了相同版本的软件包。
> rpm -ivh *.rpm     #  --nodeps --force  最好不强制安装,查看一下以来,先删除已有mysql版本(包括mariadb)

# 1.3 查看安装情况
> systemctl status mysqld

2、配置启动

2.1 修改配置文件

shell 复制代码
# 修改MySQL配置文件
> sudo vim /etc/my.cnf

# 如下:
[mysqld]
lower_case_table_names=1  # 设置表名不区分大小写
#datadir=/var/lib/mysql
#socket=/var/lib/mysql/mysql.sock
#log-error=/var/log/mysqld.log
#pid-file=/var/run/mysqld/mysqld.pid
datadir=/home/zyp/lib/mysql8.0.36/mysql   # 数据文件地址
socket=/home/zyp/lib/mysql8.0.36/mysqld.sock  # 客户和服务端通讯套接字
mysqlx_socket=/home/zyp/lib/mysql8.0.36/mysqlx.sock
log-error=/home/zyp/lib/mysql8.0.36/mysqld.log  # 日志地址
pid-file=/home/zyp/lib/mysql8.0.36/mysqld.pid   # 服务pid文件地址
character-set-server= utf8mb4                  # 数据库字符集

[client]
port= 3306
socket=/home/zyp/lib/mysql8.0.36/mysqld.sock

[mysql]
socket=/home/zyp/lib/mysql8.0.36/mysqld.sock



#注意1:修改完MySQL数据存储路径后,修改自定义文件权限(mysql会以mysql用户名写入数据,无权限报错)
> chmod 777 /home/zyp/lib/mysql8.0.36
# 注意2: 配置文件里面,数据文件目录等配置,最后不要放在/home/用户下,可能存储不足 

2.2 mysql 启动

shell 复制代码
# 2.2.1 数据库初始化
> mysqld --initialize  
> cat mysqld.log  # 初始密码 :A temporary password is generated for root@localhost: 32<8z4%s%+rI


# 2.2.1 数据库服务启动  # 用户拥有systemctl 可systemctl start mysqld
> mysqld    # 注意不要以root用户启动服务,否则报错Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!


shell 复制代码
# 2.2.3 数据库启动失败报错如上图
> yum install libaio          # 安装后解决问题(看个人电脑)
> yum install numactl
> yum isntall perl

# 启动mysql
> mysqld &  # /usr/sbin/mysqld

3、mysql 测试

shell 复制代码
# 登录并修改密码
> mysql -u root -p    # 初始密码看日志:32<8z4%s%+rI

# 修改密码
> ALTER USER 'root'@'localhost' IDENTIFIED BY 'new_password';
相关推荐
在角落发呆6 小时前
工具配置备份步骤:从手动备份到自动化方案
运维·windows·自动化
_upupup7 小时前
Linux的调试工具——gdb/cgdb
linux·服务器
百度一下吧7 小时前
Nginx 使用手册:从安装配置到实战部署
运维·nginx
JeJe同学8 小时前
Docker镜像导入、容器启动
linux·运维·docker
Jason_zhao_MR8 小时前
Linux与实时控制如何兼得
linux·嵌入式硬件·机器人·工业控制
回眸&啤酒鸭8 小时前
【回眸】自动化白盒测试落地实战指南
运维·自动化·log4j
闲云野鹤在人间8 小时前
MySQL|从理论、安装、备份到主从复制、MHA高可用详解
linux·运维·数据库·mysql·云计算
一个风轻云淡9 小时前
GCC 和 GDB命令简单解读
java·linux·前端
H.莓飛10 小时前
【数据结构】二叉树_OJ题
linux·开发语言·数据结构·算法
资料库0110 小时前
Linux 8个常见运维故障排查
java·linux·运维