mysql服务器无法启动问题处理

一台hlr服务器用网管软件登录失败,查找原因,发现网关软件连接服务器的tcp的10002端口失败,超时无应答,导致连接失败。

用户反馈核心网hlr,smc无法登录,putty登录服务器,发现hlr10002端口没有打开。出过类似问题,判断mysql没有起来,导致hlr,smc没有加载成功,netstat -tuapn|grep mysqld,发现没有显示,就是3306端口没有加载。ps -e|grep mysqld没有显示。find / -name mysql.sock,发现/var/lib/mysql/mysql.sock有显示存在这个文件。因为mysqld进程起来后,会生成此文件,正常关机后会删除此文件;启动时,若检查到此文件存在,系统会认为mysql已经启动,导致不加载mysqld进程。删除此文件,重启进程会好,但异常关机仍会出现问题,因此决定在mysqld启动前删除此文件来规避,检查/etc/rc3.d发现 S64mysqld -> ../init.d/mysqld,启动起步是64,所以必须在服务加载前执行检查,删除命令,因此在rc.sysinit中添加下面的语句进行检查删除文件,#Clean up mysql.sock

Default_Mysql_Sock="/var/lib/mysql/mysql.sock"

if -x $Default_Mysql_Sock ;then

rm -rf $Default_Mysql_Sock

fi

添加后,重启服务器,hlr,smc登录正常,问题解决。告知客户,不要随便断电关机,关机用putty下的halt命令进行。

相关推荐
print_Hyon15 分钟前
【ENSP】DHCP 基础实验(路由器作为 DHCP 服务器,接口地址池模式)
运维·服务器·智能路由器
程序员-Benothing23 分钟前
正则表达式详解:BRE、ERE、PCRE语法与实战案例
linux·运维·服务器
软件架构师-叶秋24 分钟前
V853方案之ubuntu开发环境搭建
linux·运维·服务器·全志·v853
Mortalbreeze30 分钟前
MySQL 基础篇(六):聚合查询与分组查询
数据库·mysql
晚风叙码2 小时前
MySQL 表的约束详解:从空属性到外键
android·数据库·mysql·adb
刘胡子大叔9 小时前
MySQL 升到 8.4 前的兼容性自检清单
mysql
for_ever_love__10 小时前
MySQL 主从复制讲透:binlog 原理、搭建步骤与读写分离
java·数据库·mysql·binlog·读写分离·原理·主从复制
不会就选b11 小时前
Linux之TCP理论<1>
linux·运维·服务器
小π军12 小时前
操作系统面试题
java·linux·服务器
Android系统攻城狮13 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_samples_min调用流程与实战(六十)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶